Retain ports for VOIP



  • Very simple set-up:

    Internet <-> Router (192.168.1.1) <-> pfSense 2.0.2 (192.168.0.1) <-> Network (192.168.0.*)

    There is also WAN (DHCP) 192.168.1.24 listed in pfSense's status, but I quite don't know what to make of it.

    There is one hardphone connected to the network (192.168.0.206) that I would like to use for VOIP (directly via sipgate.de, no PBX etc. in the network) via ports 5160 (SIP) and 5104 (RTP).
    The hardphone is configured to use these ports and the router is configured to prioritize traffic through these ports. It all worked very well when the Network was connected to the Router without pfSense in between.

    What do I need to configure in pfSense? Please be specific, I tried so much already with no luck. Apparently, the traffic from the hardphone on ports 5160 and 5104 gets re-NATed to different ports by pfSense. The router does not prioritize the traffic anymore and on the phone my conversation partner has a hard time hearing me if there is much traffic on the network. If there is no traffic on the network, my partner does understand me.

    Any help is much appreciated! Please be specific if possible.



  • Might it be the case that you are doing double nat with the router (192.168.1.1) in front of your pfsense?
    If so, you need to disable NAT on your router or even better, use pfsense as your router instead.


Locked