Limiter with port forwarding



  • Very happy user of 2.0.1 - have previously tried many options but now running simple dual wan single LAN setup with no extras.

    In the past I have played with limiters and never had a problem getting them to work - limiting either WAN or LAN.

    However I am trying to limit specific traffic that uses port forwarding. (I have removed any old limiters etc to be clean)

    I have two WANs and one LAN. I am running a web server and have port forwarding (port 80) set through both WAN's - which all works well.

    WAN1 is fibre and 100/20 bandwidth - so happy to leave this alone as very rarely gets even close to the limit.
    WAN2 is ADSL with 7/0.5 bandwidth. I am trying to limit traffic the internal web server to less than the bandwidth, by setting up limiters (wan2-in and wan2-out) and then assigning them to the firewall rule specific to the port forwarding.

    Unfortunately when I do this the traffic apparently does not get to the internal web server. I have tried logging this rule - and it shows request coming in and being passed - but as far as I can tell it is not getting to the web server?

    It is very reproduceable - if I disable limiter - all works fine. If I enable limiter access is stopped. In both cases the logged rule still shows traffic is passed.

    On checking traffic-shaper-queues - nothing ever shows up - no queue listing at all?

    Am I missing something or is there any way to investigate further exactly what is happening?

    TIA


Locked