Vnstat2 on 2.1 broken now that rc0


  • LAYER 8 Global Moderator

    So this was working with a bit of help before, per this thread

    http://forum.pfsense.org/index.php/topic,51396.0.html

    Now just updated to latest RC0
    2.1-RC0 (i386)
    built on Thu May 23 19:52:31 EDT 2013
    FreeBSD 8.3-RELEASE-p8

    Here is the log

    Beginning package installation for vnstat2 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading vnstat2 and its dependencies...
    Checking for package installation...
    Downloading http://files.pfsense.org/packages/8/All/vnstat-1.11_1-i386.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Additional files… vnstat_php_frontend-1.4.1.tar.gz failed.
    Backing up libraries…
    Removing package...
    Starting package deletion for vnstat-1.11_1-i386...done.
    Removing vnstat2 components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... done.
    Failed to install package.

    Installation halted.



  • Hi there,

    it seems to be a general issue!
    I just tried to update my pfsense system to 2.03 (stable i386) and get the same behavior. 2 Weeks before i could install vnstat.
    I also completely reinstalled a new system (2.03 amd64)

    Just to confirm this is my log:

    Beginning package installation for vnstat2...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading vnstat2 and its dependencies... 
    Checking for package installation... 
     Downloading http://files.pfsense.org/packages/amd64/8/All/vnstat-1.11.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/png-1.4.8.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/jpeg-8_3.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/pkg-config-0.25_1.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/freetype2-2.4.7.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/libiconv-1.13.1_1.tbz ...  (extracting)
    
       Downloading http://files.pfsense.org/packages/amd64/8/All/gd-2.0.35_7,1.tbz ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Additional files... vnstat_php_frontend-1.4.1.tar.gz failed.
    Backing up libraries... 
    Removing package...
    Starting package deletion for vnstat-1.11...done.
    Starting package deletion for gd-2.0...done.
    Starting package deletion for png-1.4...done.
    done.
    Starting package deletion for freetype2-2.4...done.
    Starting package deletion for pkg-config-0...done.
    Starting package deletion for libiconv-1.13...done.
    Removing vnstat2 components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.
    

    Any help to solve this is greatly appreciated.


  • LAYER 8 Global Moderator

    Seems can not find the frontend to grab?  Which 1.4.1 is from 2008. 1.5.1 is 2010 – be nice if the package was updated to use it vs having when it did work manually fix per the thread I linked too.

    Pretty sure can manually get it installed, but its a PITA doing that everytime you bump up to new snap, etc.



  • Excuse me, but which "linked thread" are you talking about?
    Thanks


  • LAYER 8 Global Moderator

    "Excuse me, but which "linked thread" are you talking about?
    Thanks"

    The second line in my first post..

    @johnpoz:

    So this was working with a bit of help before, per this thread

    http://forum.pfsense.org/index.php/topic,51396.0.html


  • Rebel Alliance Developer Netgate

    this should be back to normal now. Is it still broken on install?



  • Jimp - can you please clarify - do you mean that vnstat2 should now install and work ok with 2.0.3?

    TIA?


  • Rebel Alliance Developer Netgate

    The original message here about not being able to download the frontend should be corrected.


  • LAYER 8 Global Moderator

    So it working again, at least its back to how it was.  You can get it to work after you install following the instructions in the thread I linked too and doing the patch, etc.

    Would be nice if who ever maintains this package would correct it to work out of the gate, so you didn't have to apply patch, etc.  If I had more time I would look into it myself (before anyone suggests that)..  I would love to understand the packages more and how to create them, etc.  So fixing up this one would be a good learning tool.




  • @johnpoz i'm in the same boat as you.. I came up with the fix but dont have the time to learn how to fix it in the packaging system



  • I can confirm it is working again :)
    Thanks to whoever solved this.


  • LAYER 8 Global Moderator

    ^ While I agree that you can get it to work, its not like is actually fixed ;)  You have to jump through quite a few hoops to get it working..  It should be click install package = work.  Which is not the case at all.



  • I have to disagree with you.
    Just went back to my machine which was not working while I did the previous posts and installed the package without problems.

    Installed without errors and I can access vnstati frontend.
    I did not follow the instructions in the last link because with my little BSD-knowledge it was to complicated ;)


  • LAYER 8 Global Moderator

    "vnstati frontend."

    Is not the web gui frontend, this is the part this is not working and the reason for the patch and the having to copy files, etc.  This is major portion of the package - which means the package is still broken!

    see broken - and then see fixed






  • Just wondering if there had been any movement on this? I really miss this package. :(



  • Still broken in the release (cant access the front end with depreciated calls).  2.1 works great with this exception. 
    With metering being a standard nowadays I am not sure how else to function without vnstat.
    I personally thing something like this should be standard in pfsense, and not a package.

    Hopefully a maintainer can help us.



  • works for me, as long as I use the workaround I came up with.


  • LAYER 8 Global Moderator

    yeah it works just need to do the patch that is out there and can even install the 1.5 version, etc..

    I agree wish the maintainer would fix it up so it was smoother on update of pfsense, etc.  But you can get it to work without much effort.



  • Sorry for waking an old thread… but the same issue is back :(

    Beginning package installation for vnstat2 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading vnstat2 and its dependencies...
    Checking for package installation...
    Downloading http://files.pfsense.org/packages/8/All/vnstat-1.11_1-i386.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Additional files… vnstat_php_frontend-1.5.1-updated.tar.gz failed.
    Backing up libraries…
    Removing package...
    Starting package deletion for vnstat-1.11_1-i386...done.
    Removing vnstat2 components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... done.
    Failed to install package.

    Installation halted.



  • I have updated package. Waiting on one of the devs to upload the new php_frontend file.  :-[

    https://forum.pfsense.org/index.php/topic,71553.0.html

    [quote author=marcusone link=topic=62708.msg390896#msg390896 date=1390242650]
    Sorry for waking an old thread… but the same issue is back :(

    Beginning package installation for vnstat2 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading vnstat2 and its dependencies...
    Checking for package installation...
    Downloading http://files.pfsense.org/packages/8/All/vnstat-1.11_1-i386.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Additional files… vnstat_php_frontend-1.5.1-updated.tar.gz failed.
    Backing up libraries…
    Removing package...
    Starting package deletion for vnstat-1.11_1-i386...done.
    Removing vnstat2 components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... done.
    Failed to install package.

    Installation halted.


Log in to reply