Avahi install failed - Missing additional files



  • I'm trying to install the avahi package on pfsense 2.0.3-i386 but it keeps on failing due to it missing the additional files it needs.

    Loading package configuration... done.
    Configuring package components...
    Additional files... avahi.tar.gz failed.
    Backing up libraries... 
    Removing package...
    

    Now I poked around and found the xml config file that pfsense uses when installing the package and found this little part in it

     <additional_files_needed><prefix>/root/</prefix>
    		<chmod>0755</chmod>
    		http://www.pfsense.org/packages/config/avahi/binaries/avahi.tar.gz</additional_files_needed> 
    	 <additional_files_needed><prefix>/root/</prefix>
    		<chmod>0755</chmod>
    		http://www.pfsense.org/packages/config/avahi/binaries/avahi8.tar.gz</additional_files_needed> 
    

    Now… both of those files are 404. Under the avahi directory there is no binaries/ folder so I'm thinking they went missing somehow.



  • It also fails with the same error on the current 2.1-RC0 version

    Just updated this morning.
    2.1-RC0 (i386)
    built on Sun May 26 19:31:39 EDT 2013
    FreeBSD 8.3-RELEASE-p8

    I will continue to test daily and post feedback when its working. (Hopefully soon)


  • Rebel Alliance Developer Netgate

    It should be fixed as of a few hours ago.
    It now installs OK for me after I fixed it.



  • Thank you jim. Everything seems to be in place and I'm installing it now.


Locked