WLAN-Signal sehr schlecht



  • Hallo zusammen,
    nachdem mein Router (Linksys WRT320N) das zeitliche gesegnet hat, habe ich mir ein PC Engines ALIX.2D13, Bundle zugelegt und zusätzlich noch WLAN nachgerüstet. Komponenten:
    http://varia-store.com/Hardware/MiniPCI-Karten/Wistron-DCMA81-miniPCI-Extremely-Small-Size-2-4-5GHz-a-b-g::563.html
    http://varia-store.com/Antennen/Antennen-2-4-2-5GHz/Omni-Innenbereich/Omni-Antenne-5dBi-RP-SMA-Dualband-2-4GHz-und-5GHz::704.html (2x Mal)

    pfSense 2.0.3 soweit installiert und konfiguriert, jedoch das WLAN macht mir Sorgen. Die Signalstärke mit meinem Notebook (Intel Centrino Wireless-N 2330) beträgt gerade mal -78 (Gemessen mit inSSIDer). Folgende Die Einstellungen auf den WLAN-Interface habe ich als Dateianhang hochgeladen.

    Die Steckverbindungen auf der MiniPCI mit den Pigtail habe ich bereits überprüft.
    Spaßeshalber habe ich die beiden Antennen weggeschraubt um zu sehen ob das Signal schlechter wird. Signalstärke sinkt auf -90 - neben der pfSense.

    Im Vergleich, mein alter LS bringt bei 801.11g, gleiche Stelle wie pfSense auf eine Signalstärke von -31.

    Was läuft mir bei falsch? Hat jemand ähnliche Probleme?

    /Hauwech








  • Deine Konfiguration zeigt nichts Außergewöhnliches bzw. keine Fehler. An zwei Punkten könntest du noch ein wenig tunen:

    1.) Falls du nur im 2,4 GHz-g-Modus arbeitest: Klicke mal "802.11g only an" und schaue, ob sich die Signalstärke verbessert.

    2.) Egal, ob du im 2,4 GHz- oder 5,0 GHz-Band arbeitest: Du könntest versuchen unter "Channel", Kanäle vorzugeben. Ich selbst habe das gemacht, nachdem ich über einige Zeit den WLAN-Verkehr in der Nachbarschaft (inSSIDer oder Kismet) beobachtet habe. Wenn etwa starke Access Points (APs) regelmäßig auf festen Kanälen sitzen, und dein AP bei "Auto"-Einstellung immer ebenfalls diesen Kanal wählt, kannst du einfach einen freien Kanal suchen, oder aber einen, der von einem schwächeren AP mitgenutzt wird. Beste Erfahrung habe ich mit dem 5 GHz-Band gemacht, denn da funken nur sehr wenige APs. Allerdings muss ich sagen, dass ich noch nie eine Signalstärke von -31 dBm hatte, meine besten Werte liegen bei -40 dBm - und das bei qualitativ guten Karten :).

    Peter



  • Hi pvoigt,

    1. schon ausprobiert - ohne Erfolg

    2. Auf Kanal 10 habe ich 4 Striche wenn ich neben pfSense sitze. Aber das war es dann auch.

    Hast du volles Signal?



  • @Hauwech:

    Hi pvoigt,

    1. schon ausprobiert - ohne Erfolg

    2. Auf Kanal 10 habe ich 4 Striche wenn ich neben pfSense sitze. Aber das war es dann auch.

    Hast du volles Signal?

    Mit "4 Strichen" beziehst du dich vermutlich auf die Windows-Signalstärkenanzeige, die maximal 5 Striche umfasst. Ja, ich habe zwar nahezu immer "5 Striche", doch diese Anzeige ist ungenau. Besser ist es, mit inSSIDer oder Kismet "nachzumessen". Bei mir schwankt die Signalstärke schon im Verlauf eines Tages deutlich. Das ist nicht nur mit pfSense der Fall sondern auch mit meinem OpenWRT-AP. Die Signalstärke schwankt zwischen -40 dBm und -65 dBm. Wenn ich mich recht entsinne, entspricht volle Leistung einem Wert von 0 dBm.

    Peter



  • Moin,
    ich habe neben (40cm Abstand) der pfSense mit inSSIDer ca. 75dBm.



  • @Hauwech:

    Moin,
    ich habe neben (40cm Abstand) der pfSense mit inSSIDer ca. 75dBm.

    Ich vermute -75 dBm ;) - dann ist das Signal gerade so ausreichend. Die von dir verwendete Karte sollte nicht das Problem sein, und deine Antenne auch nicht, denn ich verwende dieselbe.

    Ich bin da jetzt sicher keine WLAN-Experte, doch deine Karte hat, wie viele andere auch, zwei Antennenanschlüsse, die meist mit MAIN und AUX gekennzeichnet sind. Ich habe irgendwo gelesen, dass man den MAIN-Anschluss verwenden soll, wenn man nur eine Antenne anschließt. Und das habe ich selbst auch so gemacht. Das könntest du noch einmal prüfen. Ich weiß allerdings nicht mehr, ob der AUX-Anschluss alleine tatsächlich zu schlechteren Signalen führt.

    Ich glaube nicht, dass pfSense die Karte nicht richtig unterstützt, da sie einen Atheros AR5414 besitzt. Das ist derselbe Chipsatz wie bei meiner Karte - und die läuft prima wie beschrieben.

    Peter



  • Wie finde ich heraus welcher Anschluss als MAIN definiert ist? Würde ungerne Try & Error vermeiden. :-)



  • @Hauwech:

    Wie finde ich heraus welcher Anschluss als MAIN definiert ist? Würde ungerne Try & Error vermeiden. :-)

    Wenn es nicht direkt neben den Anschlüssen direkt auf der Platine steht, wirst du wohl probieren müssen. Bei meinen Karten sind die Anschlüsse entsprechend beschriftet.

    Peter



  • Hi Peter,
    die Abschlüsse sind nicht beschriftet. Daher habe ich eine Antenne abgezogen und jeweils beide Anschlüsse getestet. Leider wird die Signalstärke dadurch nicht besser.



  • @Hauwech:

    Hi Peter,
    die Abschlüsse sind nicht beschriftet. Daher habe ich eine Antenne abgezogen und jeweils beide Anschlüsse getestet. Leider wird die Signalstärke dadurch nicht besser.

    Schade, das war aber wenigstens einen Versuch wert. Da deine aktuelle Signalstärke aber für eine stabile Verbindung ausreicht, glaube ich auch nicht, dass die Karte defekt ist. Einzig der Vergleich mit einer anderen Karte - baugleich oder nicht - würde weitere Informationen liefern. Weitere Ideen habe ich aktuell nicht.

    Peter



  • ICh sitz aktull neben dem Router! Ipad im Wohnzimmer findet das WLAN gar nicht mehr und mit dem Notebook im Arbeitszimmer 1 Strich. Das mach keinen Spaß.
    Vom Router ins Wohnzimmer, Arbeitszimmer sind es jweils nur eine Ziegelmauer.



  • Laut PC Engines sind dual-band Antennen immer ein Kompromiss. Siehe http://www.pcengines.ch/antsmadb.htm
    Diese Antenne waere demnach besser gewesen: http://www.pcengines.ch/antsma.htm



  • Den Signalpegel den du beschreibst, hat man auch wenn man überhaupt gar keine Antenne anschliesst.
    Mehrere Möglichkeiten:

    • Falscher Stecker auf der Karte (scheinst du ja schon ausporbiert zu haben)
    • Pigtail defekt
    • Antenne defekt

    Generell kannst du sagen:
    2.4GHz eine Dämpfung des gesendeten Signales von 20dB in einer Distanz von ca 12cm.
    5GHz eine Dämpfung des gesendeten Signales von 20dB in einer Distanz von ca 6cm.
    Danach steigt die Dämpfung um 6dB pro verdoppelung der Distanz.

    Wenn du also mit 20dBm auf 2.4GHz sendest, hast du in 12cm. Entfernung noch einen Pegel von 0dB.
    24cm. -6dB, 48cm -12dB, ~1m -18dB, ~2m -24dB, 4m -30dB, etc.
    Dies sind ideale Werte welche durch die Umgebung verschlechtert werden.


Log in to reply