In way over my head..



  • Long story short, I have to fix a DNS server & I have little networking knowledge.

    Here's where I am so far. Old ethernet port on the motherboard for the server is fried. New ethernet card installed. I switched all the interfaces to use the card. I assigned the LAN & the WAN an IP address (172.17.0.111).

    I set a static IP address on the laptop I'm using to configure it (172.17.0.110)

    I got halfway through setting up my VLAN's and all of a sudden the laptop cannot talk to the DNS server. At all.

    I pull up Wireshark and it's seeing the VRRP packets it's sending out. This has to do with CARP right?

    From the actual DNS server within PFSense I can ping the host (My laptop). It gets a response.

    I try to ping the server from my laptop and get nothing. The connection just times out.

    I think it's pretty clear I'm dabbling in an area that I shouldn't be, but I don't really have any options. Any help would be greatly appreciated. Thanks.



  • Yes well using Wireshark with very little knowledge of networking is insane lol! even i use it and still dont really understand it but sort of do haha. Why are you using Vlans? That sounds very technical! and if you have very little knowledge of networking, i wouldn't use Vlans can make a network very complicated. What switch are you going through? Is it anything to do with that config? What if you was to use a non managed switch and connect the DNS server to the laptop?



  • When you say "DNS server" do you mean the "simple" DNS forwarder (dnsmasq) on pfSense itself ? Or are you running some full-blown DNS server like unbound ?

    Is the system part of a redundant pair (since you mention seeing CARP/VRRP packets on the interface) ?

    In any case, start with the specific version of pfSense are you using.

    You issue could be any number of things, from flaky new NIC, to brand-new NIC poorly supported by old FreeBSD, to wrong config etc
    Try a tcpdump on the LAN interface and see what happens.



  • It runs an unbound DNS. I work for a WISP and it's our main server. Hence the VLANS. I have the server on our tech bench plugged directly into the server trying to access the webConfigurator so I can set it up just like our backup DNS server which is currently managing out network. It's running 2.0.1

    Not even sure what a tcpdump is, or how to run one…..  :'(



  • If you have plugged directly into the server without a switch or a hub. Do you not need a crossover cable?



  • Not really sure what you mean…

    It normally sits in our server room hooked up to our network through switches & whatnot. But since ethernet port went bad & it needed a new card it was taken out of there and fixed it's on our tech bench. Since PFSense was configured to use the em0 and em1 ports, I had to reconfigure it to use the re0 (The realtek card I put in it) interface.

    Now the VLAN's need to be reconfigured inside the webConfigurator. I know how to do all that. So I plugged the server directly into my laptop with an ethernet cord to set everything up inside the webConfigurator. It was working fine and all of a sudden my laptop can't bring up the webConfigurator & my laptop cannot ping the server & get a response. However, the server can ping my laptop and get a response.

    My issue is that I can no longer get into the webConfigurator from my laptop.



  • Go onto the pfsense screen and reset the web config or setup the nics again on the pfsense interface.



  • Tried that to no avail. :(

    I'm just confused as to why it was working fine, and then all of a sudden didn't want to do anything.



  • Ok excellent so you have reset the ip address on the lan interface so it should be ip 192.168.1.1. So make sure your laptop is in the same subnet 192.168.1.2…

    sorry this sounds basic just with the info your getting, in almost guessing what's happening.



  • Well, bossman decided to do away with our DNS server & make the big fish upstream do it for us so the problem solved itself!

    Thanks for all the help though.