Torrents and HTTP downloads slow



  • Hello all,

    I just recently installed pfsense and I'm loving it. I noticed that my torrent speeds are slower compared to my dlink dir-655. On the dlink I was getting over 1.0MB down, now my max speed is 600KB. I set up NAT and port forwarding correctly because utorrent is happy. The other thing I noticed while downloading world of tanks 4.8GB it took 3 hours to download.

    Please let me know what info is needed to figure this out.

    I also looked at these and they didn't seem to help http://forum.pfsense.org/index.php?topic=20264.0;prev_next=prev  http://forum.pfsense.org/index.php?topic=48519.0;prev_next=prev

    Thanks!!


  • Netgate Administrator

    Check Status: Interfaces: for the error counters on each interface. They should all be 0. You may have an interface mismatch somewhere or something as simple as a bad cable.

    What hardware are you using for pfSense?

    Steve



  • There are no errors on the interfaces. core 2 duo with 2 gb of ram





  • Netgate Administrator

    What NICs are you using?



  • I have a broadcom Gigabit onboard (LAN) Intel 100 meg pci (WAN) and dlink atheros card for wifi


  • Netgate Administrator

    Hmm, at this point it would be helpful to determine where the restriction is happening, between the client and the LAN interface (I assume you're not using wifi for this test) or between pfSense and the internet.

    You can try downloading a file directly to the pfSense box and measuring the speed:

    [2.0.3-release][root@pfsense.fire.box]/root(2): fetch -o /dev/null http://download.thinkbroadband.com/50MB.zip
    /dev/null                                     100% of   50 MB 1961 kBps 00m00s
    

    Thinkbroadband is a UK site so you may have to choose something more local.

    Also run ifconfig and post it's output here.

    Steve



  • ifconfig
    bge0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=c0098 <vlan_mtu,vlan_hwtagging,vlan_hwcsum,vlan_hwtso,linkstate>ether 00:1e:0b:32:42:6e
    inet6 fe80::21e:bff:fe32:426e%bge0 prefixlen 64 scopeid 0x1
    inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
    nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    ether 00:15:e9:81:55:e8
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=9 <rxcsum,vlan_mtu>ether 00:90:27:e5:07:cc

    nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    pfsync0: flags=0<> metric 0 mtu 1460
    syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    enc0: flags=41 <up,running>metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
    nd6 options=43 <performnud,accept_rtadv>pflog0: flags=100 <promisc>metric 0 mtu 33664
    ath0_wlan1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    ether 00:15:e9:81:55:e8
    media: IEEE 802.11 Wireless Ethernet autoselect <hostap>(autoselect <hostap>)
    status: no carrier
    ssid "" channel 6 (2437 MHz 11g)
    regdomain FCC indoor ecm authmode OPEN privacy OFF txpower 23
    scanvalid 60 protmode OFF wme burst dtimperiod 1 -dfs bintval 0
    ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    ether 06:15:e9:81:55:e8
    inet6 fe80::415:e9ff:fe81:55e8%ath0_wlan0 prefixlen 64 scopeid 0xa
    inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255
    nd6 options=43 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    ssid HESKIS channel 6 (2437 MHz 11g) bssid 06:15:e9:81:55:e8
    regdomain FCC indoor ecm authmode WPA1+WPA2/802.11i privacy MIXED
    deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit txpower 23 scanvalid 60
    protmode OFF burst -apbridge dtimperiod 1 -dfs
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ether 02:56:b2:ec:57:00
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    member: ath0_wlan0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 10 priority 128 path cost 370370
    member: bge0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 20000

    @stephenw10:

    You can try downloading a file directly to the pfSense box and measuring the speed:

    [2.0.3-release][root@pfsense.fire.box]/root(2): fetch -o /dev/null http://download.thinkbroadband.com/50MB.zip
    /dev/null                                     100% of   50 MB 1961 kBps 00m00s
    

    Thinkbroadband is a UK site so you may have to choose something more local.

    I need help with this part..^^ I have an idea where to enter the code, but I kinda need a step by step guide.</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,promisc,simplex,multicast></hostap></hostap></broadcast,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></up,running></pointopoint,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,vlan_mtu></up,broadcast,running,simplex,multicast></hostap></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu,vlan_hwtagging,vlan_hwcsum,vlan_hwtso,linkstate></up,broadcast,running,promisc,simplex,multicast>


  • Netgate Administrator

    It's probably possible to run that via the webgui in the Diagnostics: Command Prompt: page but I did that from the command line.
    Edit: It's not possible you must use the command line.

    You can access the command line either at the console directly, keyboard and monitor or serial cable, or by connecting to the box via SSH.

    Once you do that, by either method, you will see the console menu. Enter option 8 to get to the command line and enter the fetch command:

    fetch -o /dev/null http://download.thinkbroadband.com/50MB.zip
    

    You will see it update the download speed in real time.



  • The file downloads pretty slow on my pc and in pfsense. Here is my speedtest.net speeds

    ![download pfsense.PNG](/public/imported_attachments/1/download pfsense.PNG)
    ![download pfsense.PNG_thumb](/public/imported_attachments/1/download pfsense.PNG_thumb)


  • Netgate Administrator

    Hmm, why do you have no route to thinkbroadband.com? Seems suspicious.

    Also 333kbps is very slow indeed. What sort of speed do you get if download that file to a client machine?
    Edit: My mistake it's kBps. Still I get faster than that from London:

    [2.0.3-RELEASE][root@pfsense.fire.box]/root(3): fetch -o /dev/null http://filetests.hosthop.com/Large_File_Downloads/50M.zip
    /dev/null                                     100% of   50 MB  596 kBps 00m00s
    
    

    Steve



  • I will try and do some testing with my old router and download those files to see if it's any faster. Any ideas on what it might be?


  • Netgate Administrator

    Since you don't seem to have any sort or duplex mismatch or cable problem my next bet would be an MTU issue.

    That doesn't explain why you have no route to thinkbroadband though. Can you access their site?

    I assume you edited out your real WAN IPs because they are real public addresses implying your upstream device is passing them correctly to pfSense. What sort of connection is your WAN?

    Steve



  • I can access their site and I can see all the different size files to download. When I click on any of them it takes awhile to load the "Oops! Google Chrome could not connect to download.thinkbroadband.com" page. I haven't had a chance to throw my old router up and check if I can get to that site to download those test files.

    Yes I did remove my WAN IP information on purpose. I have a standard Cable internet connection from Cox Communications and my IP address is DHCP assigned. I'm currently using a Motorola DOCIS 3.0 Modem. I haven't had any internet issues before installing the pfSense box.

    I have the MTU size on the WAN interface set to use the default size.

    BTW thank you for your help!!