WAN interface with IP - sending DHCP Requests



  • Hello everybody,

    As the title says, I have a PfSense box (virtualised) that has a WAN interface with a fixed IP address but is still sending out DHCP requests.

    I've managed to capture the packets using tcpdump so know it's this server and this interface by finding the MAC address.

    Any ideas WHY this is happening?

    PfSense version: 2.0.3-RELEASE (amd64)
    Simple pfsense box with 1 x WAN and 1 x LAN interface.

    I can sort out remote access into this pfsense box if required.

    Thanks
    GE



  • @garethevans1986:

    As the title says, I have a PfSense box (virtualised) that has a WAN interface with a fixed IP address but is still sending out DHCP requests.

    I've managed to capture the packets using tcpdump so know it's this server and this interface by finding the MAC address.

    Using tcpdump where (pfSense or hypervisor)? and on which interface?

    If the DHCP requests come from dhclient on pfSense you should see them logged in the pfSense system log. What is the output of pfSense shell command```
    clog /var/log/system.log | grep dhclient



  • I did tcpdump on the pfsense box (WAN interface) and another pfsensebox upstream - both showed that the box was sending out dhcp requests.

    Results of:

    clog /var/log/system.log | grep dhclient

    Jun 2 23:31:26 firewall dhclient: FAIL (theres a few lines of this).

    System Log in PfSense:

    Jun 2 23:28:20 dhclient: FAIL
    Jun 2 23:27:18 dhclient: FAIL
    Jun 2 23:26:16 dhclient: FAIL
    Jun 2 23:25:14 dhclient: FAIL
    Jun 2 23:24:12 dhclient: FAIL
    Jun 2 23:23:10 dhclient: FAIL
    Jun 2 23:22:08 dhclient: FAIL
    Jun 2 23:21:06 dhclient: FAIL
    Jun 2 23:20:04 dhclient: FAIL
    Jun 2 23:19:02 dhclient: FAIL
    Jun 2 23:18:00 dhclient: FAIL
    Jun 2 23:16:58 dhclient: FAIL
    Jun 2 23:15:56 dhclient: FAIL
    Jun 2 23:14:54 dhclient: FAIL
    Jun 2 23:13:52 dhclient: FAIL
    Jun 2 23:12:50 dhclient: FAIL
    Jun 2 23:11:47 dhclient: FAIL
    Jun 2 23:10:45 dhclient: FAIL
    Jun 2 23:09:43 dhclient: FAIL
    Jun 2 23:08:41 dhclient: FAIL
    Jun 2 23:07:39 dhclient: FAIL
    Jun 2 23:06:37 dhclient: FAIL
    Jun 2 23:05:35 dhclient: FAIL
    Jun 2 23:04:33 dhclient: FAIL
    Jun 2 23:03:31 dhclient: FAIL

    Thanks



  • Did you originally have your WAN interface use DHCP for configuration? Have you rebooted since changing the WAN interface to static IP?

    Please post the output of pfSense shell command```
    ps ax | grep dhclient



  • I think I have but will do now.

    Output:
    $ ps ax | grep dhclient
    4905  ??  Ss    0:00.28 dhclient: em0 [priv] (dhclient)
    6498  ??  Ss    0:01.35 dhclient: em0 (dhclient)
    19730  ??  S      0:00.00 sh -c ps ax | grep dhclient
    19949  ??  S      0:00.00 grep dhclient



  • Is em0 your WAN interface?



  • Yes.

    I've also rebooted and now get this:

    $ ps ax | grep dhclient
    18155  ??  S      0:00.00 sh -c ps ax | grep dhclient
    18652  ??  S      0:00.00 grep dhclient

    GE



  • @garethevans1986:

    I've also rebooted and now get this:

    $ ps ax | grep dhclient
    18155  ??  S      0:00.00 sh -c ps ax | grep dhclient
    18652  ??  S      0:00.00 grep dhclient

    You no longer have dhclient requesting DHCP configuration on em0 (pfSense WAN interface) so you should no longer see theose DHCP requests sent on the WAN interface.



  • All sorted.

    Thank you for your time.

    GE