Open-VM-Tools [Stable 8.7.0.3046 (build-425873)platform: 2.0]



  • Since last 8 months my pfSense was plagued with packet drops and very high ping times on WAN. First I thought it has to be an ISP issue and in Jan I moved to a much better and faster high speed cable service. I rebuilt my firewall VM in expectation that the high ping times followed by packet drops for hours will be a thing of the past. Unfortunately this wasn't the case. For no good reason the WAN would behave erratically and become unstable. I changed all the CAT6 cables on my switch and anything going to the cable modem. I even called the ISP and got a brand new cable modem replacing the earlier cisco modem. But nothing seemed to work. I then though its the Intel NICs so I changed them as well. No go..still the same issue. Last weekend I moved to a beautiful ASUS RS700-E6/RS4 1U server which has 2 inbuilt Intel gigabit ports. I thought this has to be it, the old hardware must be the issue. To my bad luck the new VM would kill itself the moment I installed any packages. Only way accessible was through VMware client. Then I started to cut down everything on the system once by one. In the end I stopped installing VMTools as that was the first thing I did everytime. The moment my NICs chaged to VXN0..VXN1..etc the system stopped responding or if it responded would start high ping times on WAN and then the dreaded packet drops. I had even changed the WAN probes to a mere 10 secs with 120 bad probes before it started the alarm.

    So I dropped installing VMTools and used just E1000 and viola the UTM is flying in great speed.

    Just a word of caution for anyone using VMTools on VMware. The package is not really stable on 2.0 and the 2.1 version is broken since almost 2 months.


  • Banned

    I am running VMTools here in production on more than 10 FW's.

    NO issues WSE.

    Open-VM-tools-8.8.1



  • Have you converted the NICs to VXNet 2 ? The drivers are part of the package. Forget about VXNet 3.. I could never get those detected.


  • Banned

    No I run the E1000 drivers.



  • Yup, I thought so. The VXN 2 drivers in the VMTools package are not stable. So technically the package can't be called stable if it it breaks something.


  • Banned

    Has anybody else reported that and why do you want to add a layer of "shit" on you NIC driver?



  • VXN improves NIC performace. If pfSense package can't make a stable driver for it then it automatically goes in the "shit" category.. now does it? hmm….


  • Banned

    I havent had any improvement what so ever on the VXN.

    The true power of hardware is the diversity of drivers written for it.

    I know where i will put my money on that ;)



  • If I am not mistaken, VMware had provided the drivers for FreeBSD. Don't get me wrong here.. VMTools works, not sure what one gains by installing it other then adding drivers for network cards. I can understand VMware tools for Windows etc. but for pfSense my main goal was for VXN. If the drivers don't work, I don't want to install VMTools and break my baby ;)