Just failover, no load balancing needed. How to achieve?



  • Hi,

    After searching the forum and using the WiKi I got load-balancing working with a PPPoE DSL connection and a cable modem connection.

    However, the cable modem is very slow and I don't really want to use it round-robin. Only if my DSL fails.

    What do i need to do to just configure failover from DSL -> Cable (WAN -> WAN2) if my DSL dies.

    Would it be 1 failover pool with the two connections listed? And then a firewall rule using this as the gateway?

    Or do i need two pools?

    I am using 1.2 RC2.

    My DSL connection is PPPoE on WAN
    The cable connection is presented on OPT1(WAN2) with a gateway of 192.168.83.1

    Any hints / URLs or pointers would be much appreciated!

    Thanks
    Andy





  • Thanks,

    I have figured it out. To get simple failover (no load balancing) I just created a single failover pool. Put in WAN and OPT1 (in that order) and created a firewall rule to pass all LAN traffic out, and specified this pool as the gateway. This works fine.

    thanks

    andy



  • I created only one poll too but the tracfic still route to WAN1.
    Here is the status
    Status: Load Balancer: Pool

    Name Type Gateways Status Description
    FailOver W1->W2  gateway
    (failover)  wan  Online  Last change Nov 20 2007 14:03:55
                  opt1  Online  Last change Nov 20 2007 14:00:23

    I also created the rule allow all tracfic out
    Thanks



  • @fibble:

    Thanks,

    I have figured it out. To get simple failover (no load balancing) I just created a single failover pool. Put in WAN and OPT1 (in that order) and created a firewall rule to pass all LAN traffic out, and specified this pool as the gateway. This works fine.

    thanks

    andy

    I think I must be missing someting.

    How can you specify the pool as the gateway ?



  • Here is some slbd log :

    Club = WAN
    Orange = Backup connection (OPT1)

    Dec 12 18:12:54 	slbd[48661]: ICMP poll succeeded for 2xx.xxx.205.1, marking service UP
    Dec 12 18:12:54 	slbd[48661]: Service ClubversOrange changed status, reloading filter policy
    Dec 12 18:19:18 	slbd[51345]: Using r_refresh of 5000 milliseconds
    Dec 12 18:19:18 	slbd[51345]: Using configuration file /var/etc/slbd.conf
    Dec 12 18:19:18 	slbd[51345]: VIP 127.0.0.1:666 configured as "127.0.0.1"
    Dec 12 18:19:18 	slbd[51345]: VIP 127.0.0.1:666 sitedown at 127.0.0.1:666
    Dec 12 18:19:18 	slbd[51345]: VIP 127.0.0.1:666 added real service 2xx.xxx.205.1:666
    Dec 12 18:19:18 	slbd[51345]: VIP 127.0.0.1:666 added real service 2xx.xxx.205.2:666
    Dec 12 18:19:19 	slbd[51345]: ICMP poll succeeded for 2xx.xxx.205.1, marking service UP
    Dec 12 18:19:19 	slbd[51345]: ICMP poll succeeded for 2xx.xxx.205.2, marking service UP
    Dec 12 18:20:57 	slbd[51345]: ICMP poll failed for 2xx.xxx.205.1, marking service DOWN
    Dec 12 18:20:57 	slbd[51345]: Service ClubversOrange changed status, reloading filter policy
    

    At 18:20:57  I unplugged the WAN (Club) connection. The poll failed, but nothing happened, and no more Internet.

    Thanks !



  • @KiaN:

    I think I must be missing someting.

    How can you specify the pool as the gateway ?

    How about you read the doc?
    (….i mean i even provided a link to it in this thread..... )



  • @KiaN:

    I think I must be missing someting.

    How can you specify the pool as the gateway ?

    In the Firewall rule there is a Gateway option. That allows you to select the WAN ports or the Pools. Select the Pool you have setup


Log in to reply