Hyper-v + Pfsense 2.0.3 são ou não compatíveis



  • Boa tarde,
    Tenho lido algumas questões que o pfsense não é compatível com o hyper-v, outros dizem que funciona e etc.

    tive alguns problemas para a instalação, mas consegui instalar. Para reconhecer as placas de rede o hyper-v deve estar com as placas na forma herdada, se não, não reconhece. Após instalação não consigo conectar de outro pc o console web.

    Alguém teve esse problema?



  • Os PCs estão na mesma rede onde o pfSense está ouvindo? Qual o IP do pfSense e qual o IP do PC de onde você pretende acessar a interface gráfica? Ou melhor, você poderia especificar melhor como está seu ambiente?



  • @johnnybe:

    Os PCs estão na mesma rede onde o pfSense está ouvindo? Qual o IP do pfSense e qual o IP do PC de onde você pretende acessar a interface gráfica? Ou melhor, você poderia especificar melhor como está seu ambiente?

    Bom dia,

    Johnnybe,

    Sim,

    fiz as configurações conf. os links abaixo, ambos estão virtualizados o windows XP (acessar o webadmin) e o pfsense, ambos na faixa de ip 192.168.1.0/24





    com essa configuração o xp não consegue pingar o ip do pfsense.
    Algo configurado errado?



  • Deve ter algo configurado errado, sim. Mas acho que deve ser no Hyper-V e na forma como as placas de rede virtuais do pfSense e XP se comunicam entre si. Não conheço o Hyper-V então não posso ajudá-lo mais do que isto.



  • @johnnybe:

    Deve ter algo configurado errado, sim. Mas acho que deve ser no Hyper-V e na forma como as placas de rede virtuais do pfSense e XP se comunicam entre si. Não conheço o Hyper-V então não posso ajudá-lo mais do que isto.

    Tranquilo Johnnybe,

    vou fazer mais alguns testes, se conseguir posto aqui a resolução.



  • Percebi que é a alguma incompatibilidade do pfsense. Pois, instalei outro fw para testar e configurei da mesma forma e funcionou normalmente, consegui ter acesso o no windows xp;
    Não sei o que é?!  ???



  • Olá!

    Estou de volta ao fórum… :D

    Sobre o tópico.

    Existe sim uma incompatibilidade com o Hyper-V, não do PFSense em si, mas do FreeBSD que é usado. A versão 2.1 do PFSense já virá com outra versão do FreeBSD, tente fazer um teste com ela.



  • Olá Robson,

    Olhe minha última resposta nesse tópico, certo que ela irá te ajudar: http://forum.pfsense.org/index.php/topic,63250.0.html

    Eu optei por utilizar a versão 2.0.2, pois na versão 2.0.3 ele ainda possui uma demora na inicialização do serviço NTP.

    Abs.,

    Joe



  • @LFCavalcanti:

    Olá!

    Estou de volta ao fórum… :D

    Sobre o tópico.

    Existe sim uma incompatibilidade com o Hyper-V, não do PFSense em si, mas do FreeBSD que é usado. A versão 2.1 do PFSense já virá com outra versão do FreeBSD, tente fazer um teste com ela.

    Obrigado, LFCavalcanti
    vou tentar fazer o que me respondeu



  • @joerison:

    Olá Robson,

    Olhe minha última resposta nesse tópico, certo que ela irá te ajudar: http://forum.pfsense.org/index.php/topic,63250.0.html

    Eu optei por utilizar a versão 2.0.2, pois na versão 2.0.3 ele ainda possui uma demora na inicialização do serviço NTP.

    Abs.,

    Joe

    Sim, estou vendo seu post.. vou efetuar o procedimento e testar.

    Também não gosto muito da demora no ntp da versão 2.0.3. Em produção deixei o 2.0.2 também.



  • @Robsonsb:

    Eu optei por utilizar a versão 2.0.2, pois na versão 2.0.3 ele ainda possui uma demora na inicialização do serviço NTP.

    Este seria meu último critério de escolha.
    Pessoalmente acho péssima a idéia deixar um sistema operacional com bugs e riscos de segurança em produção por conta do tempo de boot.

    Veja o changelog da 2.0.2 para 2.0.3

    att,
    Marcello Coutinho



  • @marcelloc:

    @Robsonsb:

    Eu optei por utilizar a versão 2.0.2, pois na versão 2.0.3 ele ainda possui uma demora na inicialização do serviço NTP.

    Este seria meu último critério de escolha.
    Pessoalmente acho péssima a idéia deixar um sistema operacional com bugs e riscos de segurança em produção por conta do tempo de boot.

    Veja o changelog da 2.0.2 para 2.0.3

    att,
    Marcello Coutinho

    Marcello,

    Concordo plenamente com o que você disse.
    Por isso estou tentando fazer funcionar o meu pfsense 2.0.3 no hyper-v, conf. o outro topico (http://forum.pfsense.org/index.php/topic,63250.0.html).