Issues with 2.0.3



  • Not everything I am listing here is a problem only for 2.0.3.

    1. This is a new 2.0.3 issue. After install 2.0.3 hangs waiting for an NTP connection when there is no WAN connection. It also seems to hang longer waiting for a DHCP WAN connection. I do not have these issues with 2.0.2 or 2.1, I have used various builds including some of the rc0 builds, and not had this issue.

    2. When applying a config, I am usually taken to the interfaces screen to resolve interface issues. This is always a pain especially if I need to setup LAGG groups as LAGG groups will not show up. I tried installing 2.0.2 and applying a config from another box using 2.0.2 and after clicking save and waiting 30 minutes, the system still did not reboot. 2.0.3 would eventually reboot, but I had too many issues with the boot up process hangs and once it was finally ready, adding LAGG groups and other interface changes were met with long delays after clicking save. It was mind numbing. I ultimately used a 2.1 rc0 build and everything worked in acceptable time frames.

    3. Related to the above, when a config is applied and the interface screen is presented, why can't lagg groups be created and used for vlans, etc.

    4. When using the console why can't interfaces be changed without destroying all rules, etc. e.g. I just want to change the physical or virtual interface used by the pfSense interface, but I can't get in to the web interface. This was an issue quite a bit when I was applying my 2.0.2 config and I could not add the necessary interfaces at the time the config was applied. So I would try to assign the physical interface at the console, bit that would just blow out all the interface rules. The fact that I had applied a config was worthless once I made the interface changes at the console.