PfSense LAN/WAN interface changes for DHCPv6-PD from 2.1 DEV to 2.1 RC0



  • Hello,

    I actually have:
    PFSense 2.1-DEVELOPMENT (i386)
    built on Fri Nov 25 14:30:42 EST 2011
    FreeBSD 8.1-RELEASE-p6

    and I was trying the new 2.1 RC0 build:

    2.1-RC0 (i386)
    built on Sat Jun 8 06:42:11 EDT 2013
    FreeBSD 8.3-RELEASE-p8

    When configuring WAN/LAN for the settings required by my ISP (which offers IPv4 and IPv6 via PPPoE and DHCPv6-PD ((RFC 3769) I found the following changed from DEV to RC0 and was wondering how can I configure PFSense to achieve the same results I now have on 2.1DEV.

    Settings on 2.1 DEV:

    Settings on 2.1 RC0:

    Observe the missing DHCPv6 Unique Identifier (DUID) from the WAN settings on the RC0 build.

    On the LAN side, it gets even more different:

    Settings on 2.1 DEV:

    Settings on 2.1 RC0:

    Please note the missing DHCPv6 Prefix Delegation ID <id>This ID sets the delegated DHCP-PD prefix number which will be used to setup the interface.

    Is there any other way to configure this ?

    I’ve managed to make the connection work also with a cisco 881, but would still want to use PFSense.

    If it helps, here is the config on the cisco:

    ipv6 unicast-routing
    ipv6 cef
    !
    vpdn enable
    !
    vpdn-group pppoe

    WAN Interface

    interface FastEthernet4
    no ip address
    ipv6 nd ra suppress
    duplex auto
    speed auto
    pppoe-client dial-pool-number 1 service-name "ipv6test"
    no cdp enable
    !
    interface Dialer1
    mtu 1492
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    ipv6 address dhcp
    ipv6 dhcp client pd DH-PREFIX # here we set the prefix
    ppp pap sent-username <user>password 7 <pass># my PPPoE user/pass
    no cdp enable

    interfata LAN

    interface Vlan1
    ip address 192.168.1.1 255.255.255.0
    ip tcp adjust-mss 1452
    ipv6 address DH-PREFIX 0:0:0:1::/64 eui-64 # ISP Offers /64

    Any help would be greatly appreciated.

    Thanks.</pass></user></id>



  • On the LAN side, you have to set the “IPv6 Configuration Type” field to “track interface” for DHCP-PD. This will give you fields to select which interface to track (WAN), and which prefid ID to use.



  • That said, there are still some issues being sorted out with DHCP-PD; see this thread in the 2.1 snapshot section.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy