Barnyard2 startup Error: Undefined variable name.



  • Hello all,

    I installed snort and set it to output to unified 2.  I can start snort just fine and generated some alerts and can see the snort.u2.**** files are filling up.  I also have a barnyard2.waldo file that is set at zero bytes.  When I try to start barnyard2, I get the error:

    ERROR: /usr/local/snort/etc/barnyard2.conf(355) Undefined variable name: .

    In my barnyard2.conf, line 355 is for the output database:

    output database: log, mysql, user=snort password=*** dbname=snort host=localhost

    In my snort.conf I have:

    output unified2: filename snort.u2, limit 128

    So snort is logging to that snort.u2 file but I cannot start barnyard due to the undefined variable name issue.

    The command I am using to start barnyard2 is:

    /usr/local/bin/barnyard2 -c /usr/local/snort/etc/barnyard2.conf -d /var/log/snort -f snort.u2 -w /var/log/snort/barnyard2.waldo

    Any thoughts?

    I have tried many things and scoured the internet to no avail.



  • Well after all of that effort, I realized that it didn't like the symbols in my snort user DB password.  I took out the periods and the error went away.  Hopefully this will help someone in the future from banging their head on the wall :)



  • Wow, I spent the whole day looking for a solution to this same problem. That's when I found this topic. In fact, it does not accept passwords with special characters. It was only to change to a simpler password that worked.

    It is a old post, but, was only to help the community.