WARNING when using ramdisk /var and squid



  • i had a stupid fail today with squid constantly crashing and then us losing net access because we use transparent mode

    if you enable the ramdisk /var & /tmp partitions option and set the Hard disk cache size sufficiently high enough (any value higher than your /var RAM Disk Size setting) you will be prone to breaking squid with crashes logging a disk full error

    The solution in this case is to move the squid cache dir (default is /var/squid/cache) outside of /var - I changed mine to /squid/cache and it resolves the issue for us)

    It would probably be a good idea for some basic logic in the squid config pages to auto change this default when ramdisks are enabled or at the very least place a warning on the local cache tab to the same effect