Latest 2.1 snapshot causes vlan phsyical interface to flap nonstop



  • Hello All,

    the latest available snapshot (Tue Jun 11 18:14:42 EDT 2013) causes my vlan interfaces to flap nonstop after upgrading. I had to downgrade back to (Mon Jun 10 17:11:27 EDT 2013) to get the system to stop spamming link up/down for the vlan psychical interface. Going back to the older snapshot has no problems.

    I should note that I use CARP on the vlan interfaces.

    Regards,

    Jon


  • Rebel Alliance Developer Netgate

    The more important question is what type of interface is the parent of those VLANs?



  • The parent of the vlans is a em driver interface. I saw no errors on the switch side just that the interface was stuck in a linkup/down loop. The only thing I saw on the pfsense side was hotplug events like this:

    Jun 12 01:16:11 dam02 check_reload_status: Linkup starting em1
    Jun 12 01:16:11 dam02 check_reload_status: Linkup starting em1_vlan5
    Jun 12 01:16:11 dam02 check_reload_status: Linkup starting em1_vlan6
    Jun 12 01:16:13 dam02 php: : waiting for pfsync…
    Jun 12 01:16:13 dam02 php: : pfsync done in 0 seconds.
    Jun 12 01:16:13 dam02 php: : Configuring CARP settings finalize...
    Jun 12 01:16:13 dam02 check_reload_status: Linkup starting em1
    Jun 12 01:16:13 dam02 kernel: em1: link state changed to UP
    Jun 12 01:16:13 dam02 kernel: em1_vlan5: link state changed to UP
    Jun 12 01:16:13 dam02 kernel: opt3_vip3: INIT -> BACKUP
    Jun 12 01:16:13 dam02 kernel: em1_vlan6: link state changed to UP

    Just those over and over again nonstop on the vlan parent and subinterfaces.

    Regards,

    Jon


  • Rebel Alliance Developer Netgate

    So the problem likely has nothing to do with VLANs, but em1 going down and back up. The VLANs follow the same transition because the parent does it.

    I don't see anything that would have affected em in the commits though.



  • Yeah not sure why myself, but just downgrading to the previous snapshot fixes the issue with em. I didnt do any config changes between the two.



  • Try disabling flow control in the em driver.
    Probably that is causing the link flapping.



  • Hello,

    The switch that the em device is attached to doesnt support flow control, but I will try it anyways and see what happens.

    Thanks,

    Jon



  • Hello,

    I just checked my settings and I have flow control disabled already along with some other settings:

    hw.em.num_queues=4
    hw.em.rxd=4096
    hw.em.txd=4096
    hw.em.fc_setting=0
    hw.em.lro=0
    hw.em.max_interrupt_rate="32000"

    This is in /boot/loader.conf.local and has been there for the past year or so.

    Regards,

    Jon



  • I just loaded up the Thu Jun 13 16:43:07 EDT 2013 snapshot, and the problem is gone. I think there must have been a glitch with the snapshot I tried last time, all is fine with this new one.