Pfsense. squid doesn't work in transpatent mode.



  • I installed 2.0.3-RELEASE (i386). However, I got an issue
    on squid now. It is not working as transparent proxy. In "non-transparent" mode everything works good.

    Issue is whenever someone browse a website, he always got

    The following error was encountered:
        * Invalid Request

    Some aspect of the HTTP Request is invalid. Possible problems:
        * Missing or unknown request method
        * Missing URL
        * Missing HTTP Identifier (HTTP/1.0)
        * Request is too large
        * Content-Length missing for POST or PUT requests
        * Illegal character in hostname; underscores are not allowed

    Proxy Interface is LAN. i checked http://forum.pfsense.org/index.php?topic=40509.0;prev_next=next but i don't have this exrtra string.
    How can i solve this?


    well, i found that https sites can be browsed properly.
    can't find spoiler, so i'll write down
    WORKS https://www.google.ru/
    WORKS https://www.openstat.ru/
    DOESN'T WORK russia.tv
    DOESN'T WORK http://ru.pokerstrategy.com/



  • This has happened to me as all but just for a few seconds after configuring squid alone!
    But when i added squidguard and restarted pfsense, it was working as it should be.



  • Squid in transparent mode does not proxify HTTPS. That's why https://google.ru and https://www.openstat.ru works.

    Кстати, здесь есть русская ветка форума



  • @srk3461:

    This has happened to me as all but just for a few seconds after configuring squid alone!
    But when i added squidguard and restarted pfsense, it was working as it should be.

    i added sqdgrd, configered it, restarted pfsense - nothing changed.



  • @Vadim:

    @srk3461:

    This has happened to me as all but just for a few seconds after configuring squid alone!
    But when i added squidguard and restarted pfsense, it was working as it should be.

    i added sqdgrd, configered it, restarted pfsense - nothing changed.

    Do you have anything added under access control !? Did you check "allow users on this Interface" on squid's front page i.e General Tab!
    Make sure to clear cache memory of your browser's first!
    If possible post some screen shots of squid!?



  • @srk3461:

    Do you have anything added under access control !? Did you check "allow users on this Interface" on squid's front page i.e General Tab!
    Make sure to clear cache memory of your browser's first!
    If possible post some screen shots of squid!?

    well, in ac tab is written " Note that the proxy interface subnet is already an allowed subnet" so i left it blank. Chekbox in "Allow users on interface" is marked.  But i discovered that http://forum.pfsense.org/index.php?topic=40509.0;prev_next=next is exactly my case. When i opened config file after i marked "Transparent proxy" and applied changes i found that "extra string". Manual correcting partly solved my problem: transp mode works normal but i can't change anything in "Proxy server: General settings" otherwise my changes are overwritten and i get the same issue.


Log in to reply