Kernel: in_scrubprefix: err=65, prefix delete failed



  • 2.1-RC0 (amd64)
    built on Tue Jun 18 18:57:41 EDT 2013

    I noticed that when I disable carp on the secondary or primary I get an error in the system logs.  I have 3 interfaces with 2 using carp.  One of the interfaces is a sync interface. I have 1 carp vip on LAN and 1 on WAN interface but I have a few alias IPs on the WAN Carp IP.   I just started testing 2.1 with carp so I do not know if it has always done this on 2.1.  It does not happen on the stable 2.0.3 version though.

    I don't see any issues so I assume it is nothing to worry about but I figured I would report it anyway just in case.  I google search mentions something about removing ipv6 route or something and it appears right after the link state goes down so maybe it is a timing issue or order issue of something being done.  I do not use ipv6 btw.

    On 2.1 RC0:

    Jun 19 10:21:48	kernel: lan_vip2: link state changed to DOWN
    Jun 19 10:21:48	kernel: in_scrubprefix: err=65, prefix delete failed
    Jun 19 10:21:49	kernel: wan_vip1: link state changed to DOWN
    Jun 19 10:21:49	kernel: in_scrubprefix: err=65, prefix delete failed
    Jun 19 10:21:50	kernel: wan_vip3: link state changed to DOWN
    Jun 19 10:21:50	kernel: in_scrubprefix: err=65, prefix delete failed
    Jun 19 10:21:51	kernel: wan_vip4: link state changed to DOWN
    Jun 19 10:21:51	kernel: in_scrubprefix: err=65, prefix delete failed
    Jun 19 10:21:54	php: : Message sent to x@x.x OK
    Jun 19 10:21:59	php: : Message sent to x@x.x OK
    Jun 19 10:22:04	php: : Message sent to x@x.x OK
    Jun 19 10:22:06	check_reload_status: Syncing firewall
    Jun 19 10:22:06	syslogd: exiting on signal 15
    Jun 19 10:22:06	syslogd: kernel boot file is /boot/kernel/kernel
    

    On the official 2.0.3 version:

    Jun 19 14:35:30	kernel: vip1: link state changed to DOWN
    Jun 19 14:35:31	kernel: vip2: link state changed to DOWN
    Jun 19 14:35:32	kernel: vip3: link state changed to DOWN
    Jun 19 14:35:33	kernel: vip4: link state changed to DOWN
    

Log in to reply