Hard drive compatibility question



  • I've been testing the LiveCD version of pfSense 2.0.3 and 2.1 on some existing hardware. I'm looking to purchase the same motherboard and processor below for my dedicated pfSense box once I'm done testing. So I need to be sure there are no driver issues with the motherboard (or other hardware) before I spend money.
    Gigabyte GA-78LMT-USB3
    AMD Athlon II X2 270
    Transcend DDR3 1033 MHz RAM 2GB x 3
    Toshiba 500 GB SATA HDD
    LG DVD Writer

    Whenever I try to boot from CD with the HDD connected, the page tends to get stuck at this screen:
    Verifying DMI Pool Data …............
    AMD Data Change...Update New Data to DMI!
    Boot from CD/DVD : CD Loader 1.2

    Building the boot loader arguments
    Looking up /BOOT/LOADER... Found
    Relocating the loader and the BTX
    Starting the BTX loader

    BTX loader 1.00 BTX version is 1.02
    Consoles: internal video/keyboard
    BIOS CD is cd0
    BIOS drive C: is disk0

    and right after this, it gets stuck, and does not proceed any further.
    Every time I had the HDD connected, it would get stuck here, and wouldn't proceed. But whenever I disconnected the HDD, and only left the optical drive connected, it used to just zip so fast past this screen that you couldn't even read any of it.

    I wanted to try seeing if it worked with the HDD one last time, so I tried this again. This time, I wanted to write down everything on the screen when it 'froze', and report over here to see what the problem was. So to my surprise, as I was nearing the end of writing everything down, it began to proceed. And then everything loaded fine.

    But you should still know I retried this several times with the HDD connected, and it still ends up sorta hanging on that screen for a long, long time. You could probably go have a small snack, and then a soda to wash it down with, and come back, and it would still be stuck there and not move forward. It doesn't happen when the drive is not connected.

    So I just want to know - this is not any compatibility issue or driver issue with either my particular hard drive, or the motherboard's storage controller, is it? I shouldn't worry about this, right?
    Because I don't want to face any problems with installation of pfSense to the hard disc after I have bought everything, and nor do I want the installation to crash after it has been running for a while.

    You should note that a few days ago, I tried booting into LiveCD, and even installing pfSense to a test hard drive. The hard drive is an 8-year old spare I have lying around, that has not been used for the past year and a half. It still seems to be in working condition.
    HOWEVER, after I had finished installing, and as I was trying to test pfSense from a browser from another machine across the network, something happened (don't remember what) that made my reboot the machine. And then, pfSense refused to boot into the installed version, and kept giving me a 'root mount error' message, and it just got genuinely frozen on that screen.

    Now, I suspect this could have been because of a failing, frail old hard drive, but just want to make sure this isn't a compatibility issue with the motherboard's storage controller.



  • What was the state of the USB3 controller during this? (enabled/disabled in BIOS?)

    What disk mode has been set in BIOS? It seems FreeBSD boot is less troublesome if the BIOS sets disk controllers into LEGACY or IDE or similar mode rather than SATA or RAID or ADVANCED or similar.

    @reachrishikh:

    And then, pfSense refused to boot into the installed version, and kept giving me a 'root mount error' message, and it just got genuinely frozen on that screen.

    Can you give the exact text of the message and a few preceding lines? There is not enough information to uniquely identify the class of problem.

    And what is the history of that drive? Did you install on the same computer or on another computer then moved the drive?



  • USB3 was disabled, like you had suggested in the other thread.
    There is no option called Disc Mode in my AWARD BIOS, but there is one called 'OnChip SATA Type', and the options are 'Native IDE', 'RAID', and 'AHCI'. It's been set to Native IDE.

    Exact message, erm, well you've already seen the case-history of how I got that message in the other thread. Thing is, I didn't write it down at that time, and now I'm not going to try reproducing that problem with that hdd since I know it was causing problems with my hardware. Can't risk spoiling that machine.

    The drive used to be the OS drive of an older computer. Then we got rid of the computer, so I formatted it, and used it as a secondary data drive for a while. Used to store movies on it, I guess. Then I stopped using it altogether when we got a bigger primary data drive.



  • I can think of two reasons the startup might report a "mount root error";
    1. An i/o error is seen while processing the file system metadata needed for the mount. An i/o error would normally be reported in this case. This probably can't be easily recovered.
    2. The drive has a different physical name (e.g. /dev/ad2) from the location identified for the root file system in /etc/fstab. This is fairly easily recovered if its due to a drive move.

    Without more detail I can't distinguish between these.



  • Okay, but neither of these mean that the motherboard's storage controller is not supported with drivers in pfSense, right?



  • @reachrishikh:

    Okay, but neither of these mean that the motherboard's storage controller is not supported with drivers in pfSense, right?

    If you want a statement of support you should look at the official FreeBSD Hardware Compatibility List (HCL), e.g. at http://www.freebsd.org/releases/8.3R/hardware.html or http://www.freebsd.org/releases/8.1R/hardware.html however those lists shouldn't be considered to be complete in that there are expansion cards and motherboards containing supported chipsets but those cards and motherboards are not listed in the HCL.



  • Okay, I'll look into the hardware compatibility list, and write back.

    But in the meantime, could you tell me about the other thing I mentioned in this thread - about the booting process getting stuck at drive C: is disk0 screen whenever a hard drive is attached? Is this normal? Is this not normal?



  • Can you please update if this motherboard worked for you?

    I am looking at building a pfSense box with this hardware…I too want to use a SATA HDD due to how I am hoping to use this:

    • firewall
    • proxy (reason for HDD)
    • SIP Proxy
    • cache (other reason for HDD)
    • VPN "server"
    • Dual-WAN