Is it possible to restore the configuration from pfsense 2.0.1 to 2.0.3?



  • Answer please? can there be any problems?



  • Well, I just had to revert to 2.0.1 from a failed upgrade to 2.0.3. I had exported the settings from the firewall when it was running 2.0.3 and restored them to the machine after reinstalling 2.0.1 and it worked just fine. I wouldn't hesitate to go the other direction.

    Besides, what do you have to lose?

    If you're nervous, take screen captures of the firewall rules for each port so you can easily recreate the rules if you need to, but I don't think you will.

    Van



  • Thanks for the reply, I care about the work that is of some packages. Why at repairing the configuration pulled the new package version 0.6 openbgpd not old, but in the config file exactly spelled out what should be 0.5.6. As a result, no working BGP!



  • In general the configuration is compatible between 2.0.1 and 2.0.3 or 2.1
    So no need to worry when upgrading.

    But you are absolutly right - when upgrading the pfsense system to a newer version then all packages will be upgraden/re-installed. But in general - again - the config between the package versions are the same.

    Sometimes you need to reboot after a firmware upgrade or just go to the GUI of the package and click "save" again so the the config files will be written correctly.



  • I understand, thank you. I'll try to


Log in to reply