Hacom CV863A3U10E documented.



  • Oh, the horrors!  I documented in the wiki how to get this beast working properly.  Proceed with caution!

    http://wiki.pfsense.com/wikka.php?wakka=Hacom



  • Thanky ou for putting that together. Very valuable information!  :D



  • I am currently trying to install Beta2 to a CV863A4R10E (4x 10/100 version of the same unit).  I have Beta-1 working fine on a flash but want to move to a Microdrive to allow for installing packages [3gb Hitachi].

    However, I have been unable to boot the CD and use the HD due to DMA read timeouts.  When I used these drives previously with Linux on the same boxes, I needed to disable DMA in the OS (I've already disabled it in Bios and set PIO to Mode-0 as recommended in the Wiki posting above).

    Is there any way to disable DMA during the boot process?  If not, does anybody have any ideas on how I might work around this issue?

    Things I've done:
    a) Disable DMA in Bios
    b) Force PIO Mode 0 and 3 (not tried 2 or 4 yet)
    c) Tried both settings of CH1 (foorce IDE2 between ATA 33 and 100/66)
    d) Tried both settings of JCF2 (set the CF card between primary and secondary

    I have not tried booting in an alternate boot mode because I do not have the PS/2 adapter cable :(



  • OK - to answer my own question…

    Based on this post [ http://m0n0.ch/wall/list/showmsg.php?id=73/62 ], I edited the /boot/loader.rc file on the ISO and added the following 2 lines to the very top:

    set hw.ata.atapi_dma="0"
    set hw.ata.ata_dma="0"

    Then burned the ISO and booted - pfSense now loaded in PIO mode and everything worked fine.  The setting was retained during the install.

    Question for the developers - Will the pfSense update process lose these changes or am I now good until I need to do a new full install?

    For reference I used a trial of a program called UltraISO to edit the file.  You need to extract the file out of the iso, edit it, then paste it back in and save your new ISO.  http://www.ezbsystems.com/ultraiso/index.html


Locked