Ubuntu lan atftpd +pfsense = phones cannot fetch tftp, -pfsense=works



  • I replaced an isp router with pfsense.

    I have atftpd setup on an always on ubuntu workstation to provide configuration to IP phones.  Without tftp the phones don't have full functionality (after reboot).

    when I switched to pfsense the phones (on the same subnet as tftp) could not fetch their tftp configs.  Not even when setting the lan ip address of the server in dhcp server settings o pfsense.  Neither manually specifiying tftp server address in phones

    remove pfsense putting back previous router and the phones can fetch via tftp

    pfsense is the problem

    because the isp router causes no end of voip problems I put pfsense back in place.

    added pfsense package tftp enabled on lan.  the phones are not fetching from pfsense tftp.  Sadly pfsense tftp logs don't have an option to show in system logs, and I cannot see tftp logs

    this problem occurs with both pfsense versions 2.0.3 and 2.1-RC0 Jul3.

    isp dhcp wan, 1 wan, 1 lan, no vlan, on subnet for all, all voip devices have static reservations,

    I need to setup a set of new ip phones and cannot without tftp.  rrrg.

    kind advice will be warmly received



  • @needclues:

    when I switched to pfsense the phones (on the same subnet as tftp) could not fetch their tftp configs.  Not even when setting the lan ip address of the server in dhcp server settings o pfsense.  Neither manually specifiying tftp server address in phones

    Not enough information. It is not obvious how pfSense would get in the way of the phones accessing the tftp server.

    I presume the phones start with issuing a DHCP request and expect the response to include the IP address of the tftp server. Correct?

    After you specified the IP address of tftp server to the pfSense DHCP server did you restart (disable then enable) the DHCP server so it would notice the configuration change?



  • Would it be possible to see your LAN firewall rule?



  • I got it! ;D

    What's needed is a -s /tftpboot on the configuration - now I'm looking for where that is!
    without it, tftpd thinks / is server root




Log in to reply