After upgrade 2.0.1 > 2.0.3, system log full of lighttpd[24549]: errors



  • I upgraded a production (domestic) system running 2.0.1 to 2.0.3 about 14 hours ago. It seems to be functioning well, however the system log is now full of these:

    Jul 15 18:38:16 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:16 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:16 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:16 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:16 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jul 15 18:38:17 lighttpd[24549]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request

    I'd appreciate any advice as to how to proceed.



  • See http://forum.pfsense.org/index.php/topic,62636.msg338214.html#msg338214 for some hints. Or search the forums for SSL23.


  • Rebel Alliance Developer Netgate

    On 2.1 I added a checkbox to disable the lighttpd logs since for many people they're just a source of log spam…



  • Thanks for the replies. I should have posted in installation and upgrades - maybe thread could be moved.

    I have virtually the same setup as the OP linked in wallabybob's response - non-standard https port for the webgui, same packages installed except that I have snort as well.



  • where can I find the check-box to disable the lighttpd logs in Version 2.1.5-RELEASE (amd64)
    built on Mon Aug 25 07:44:45 EDT 2014 ?

    thank you

    edit: found it

    ![2015-01-26 22.51.56.jpg](/public/imported_attachments/1/2015-01-26 22.51.56.jpg)
    ![2015-01-26 22.51.56.jpg_thumb](/public/imported_attachments/1/2015-01-26 22.51.56.jpg_thumb)


Log in to reply