Squid3 proxy on pfsense question. it about error Invalid URL.



  • Hello everyone,

    I've installed squid3 proxy server on pfsense as package.
    the pfsense have two ethernet.
    one ethernet is WAN,
    other one is LAN.
    So now my router connected on LAN ethernet of Pfsense.
    My configured diagram same like following;
    [WAN1]–------[router]–--------------[switch1]–--------[PC1]
                            |          LAN1
                            |          LAN2
    [WAN2]–-----[pfsense]–-------------[switch2]–---------[PC2]

    So the PC1 trying to open google(http://www.google.com), when it is using as port 80, then router route to pfsense proxy server using destination nat.
    And then squid3 proxy server working.
    SO the PC2 working well with squid3 proxy server when open the websites.
    But the PC1 trying to open the websites, then the error it Invalid URL occured.

    Have anyone solved it this problem as same like me?
    ![squid error.png](/public/imported_attachments/1/squid error.png)
    ![squid error.png_thumb](/public/imported_attachments/1/squid error.png_thumb)



  • Sorry, the upper diagram is not correct.. I modified it as following;

    [WAN1]–------------------------------[router]–--------------[switch1]–--------[PC1]
                                                            |          LAN1
                                                            |
                                            LAN2        |
    [WAN2]–-----[pfsense]–-------------[switch2]–---------[PC2]