[SOLVED] Internal NIC dies, lights off att "Configuring firewall"



  • TLDR:
    Replaced the NIC, so far so good.


    First of all, I'm not really a network guru, nor know very much about Linux. With that being said:

    I used ClearOS for a while, but for some unknown reasons the port forwarding module stopped working so I decided to switch to pfSense, hoping I could learn something in the process as well.

    Anyway, a few weeks or so ago my internal NIC just randomly died. Lights went off and everything. Rebooting the machine didn't help - I had to power off the machine and then power it on again.

    Everything worked fine for another week, then the same thing happened again. So i powered down, and powered up.

    Another week passes, and it again dies. This time power down/up doesn't work.
    The lights on the NIC are on during boot-up, and as far as I can see the light go off when pfSense does "Configuring firewall".

    I then tried updating to the latest release last night (I use the ipv6 beta release) - to no avail.

    Then I proceeded to reset to factory defaults. But my internal NIC was dead the entire time here …

    My External NIC works fine, and is integretaed in my desktop Dell Optiplex 760. I believe it's an intel-card of some kind.

    My Internal NIC is Realtek os some make. I don't know how to find out their exact versions.

    Another weird thing is, last night, I made the reset to factory defaults. The Nic lights were off and I gave up and went to bed.
    When I woke up, it was on and stuff seemed to work fine.
    Now however, after I went through the configuration guide through the web interface it died again :(

    So what's wrong? Do I need to replace the internal NIC (I'd rather not) or can I solve this in another way?

    EDIT: Internal NIC is Dlink DGE-528
    External NIC is Intel pro 7.3.2

    I found this when googling:
    http://tech.slashdot.org/story/13/02/06/2024251/intel-gigabit-nic-packet-of-death

    Could that be it? I don't understand it, stuff has worked fine for months. Is it a virus? How do I fix it? :/
    Sadly I don't know how to find out if I have 82574L or not.
    Packet of death ... meh.

    EDIT#2: Just reformatted and installed 2.0.3 - everything looked fine, but again at "Configuring firewall" the light on both the NIC and the switch went off.



  • Try installing 2.1.  There is broader chipset support in it.



  • @tim.mcmanus:

    Try installing 2.1.  There is broader chipset support in it.

    I've tried 2.1 RC0 without success.
    Just so you don't misinterpret me - pfSense has worked flawlessly since April - and only now started acting up. Or maybe it's my NIC. Anyway, I ordered a new one and hope it'll help.