Downgrade from 2.0.3 to 2.0.1



  • Hello,

    I have just upgrade my PfSense from 2.0.1 to 2.0.3. But I have a problem, Siproxy doesn't work at all.

    I need to go back 2.0.1.

    I use a 4GB CF card, so I guess I have the "2 system banks", who will give me the ability to go back to an old version.

    Where can I found this feature ? I have use it a long time ago, but this one doesn't pop-up on my screen !

    Thx

    Phil



  • Diagnostics->NanoBSD lets you switch slices, So you can switch back to the old version and test. I think the config should be OK to run with 2.0.1 and 2.0.3.
    Then report back your results, what messages are in the system log when it works and does not work?…
    It would be best for others to sort out what your problem really is, and if it is some general problem it can be fixed for everyone.



  • Hi Phil,

    Maybe the only menu I don't have check, sorry for the N00b question  ;D.

    At home, the SIP (Siproxd ) is a major feature regarding the WAF, so I had to revert back to 2.0.1 in emergency.
    This evening I'll do extended tests, I can reboot the firewall. I'll start again the upgrade from my current stable 2.0.1 and see what happened in details.

    To keep a trace of what happened yesterday evening :

    • upgrade using GUI from rock stable 2.0.1 to 2.0.3
    • everything OK, but the Siproxd package failed.
    • Services -> Siproxy, dead page, PHP error.
    • Re-install the SIP proxy module, then always PHP error, but less, menu appear with the 3 tabs, but no device registered.
    • Reboot, then everything OK in the GUI, but no registered device.
    • Last 500 entry of system logs flooded with Siproxd error.

    Thx for your help,

    Phil

    PS : btw, I've received my new Intel NUC + 32GB mSATA + a USB<->ETH adaptor. Maybe I'll start a new PfSense 2.0.3 HDD installation and have this device ready for debug.



  • Thanks for the details but it would be more helpful to have the exact text of the messages than the executive summary siproxd error.

    @phil242:

    • Services -> Siproxy, dead page, PHP error.

    Again, please provide text of the message.

    @phil242:

    • Re-install the SIP proxy module, then always PHP error,

    Again, please provide text of the message.

    I have siproxd installed on a pfSense 2.0.3 system but my soft phones register with VOIP provider so I don't think I'm using it.

    @phil242:

    I've received my new Intel NUC + 32GB mSATA + a USB<->ETH adaptor. Maybe I'll start a new PfSense 2.0.3 HDD installation and have this device ready for debug.

    I wouldn't be surprised if that hardware is too new to work with either pfSense 2.0.3 or 2.1. But I would be interested to read how you get on with it.



  • This evening or tomorrow I'll play again the scenario and keep a track of everything, don't worry  ;). I use PfSense since years, if I can contribute to solve something I would be happy.

    I'm not a really advanced user regarding the SIP, but I'll do my best.

    For the NUC, it's a try. I have repaired 2 times my Openbrick (chemical capacitors), and I'm tired of it and it's bad design for the eat …  Yesterday I have assemble the parts (RAM+mSATA), it's ready for a test with an USB eth card (I have choose a model supported in FreeBSD).
    If it'll not work, I'll use it as a HTPC + Openelec : I already own another NUC, it's THE perfect HTPC (for my needs).



  • Done again the upgrade at the second : everything is OK out of the box …

    The previous scenario happened like it's said before, but no log of it, 1000x sorry.

    Something present in 2.0.1 and always present in 2.0.3 :
    About 45 time per minute I have this entry in the system log :

    siproxd[32769]: siproxd.c:444 ERROR:sip_message_parse() failed… this is not good

    Later I'll report in another post the Intel NUC install, USB stick ready for HDD install, just need to find a few seconds to try it.

    Phil