SOLVED: OpenVPN Disable IPv6?



  • My PfSense box's hard drive crashed over the weekend and I had just made a config backup the day before. So reloaded the new drive with yesterdays i386 snapshot (my previous snapshot version was earlier this month) and restored the config. Everything seems to be working fine except OpenVPN. I cannot connect from the outside at all. I looked at the OpenVPN logs and then my firewall logs and I noticed that the firewall is showing the OpenVPN interface with a IPv6 address as blocked. I do not have IPv6 traffic enabled on this box so that explains why it is blocked. However, how can I disable IPv6 in the OpenVPN settings? The fields are blank in the OpenVPN settings for both the local interface and gatway under IPv6. I noticed in the OpenVPN log that on of the lines reads "do_config, tt ipv6=1" I've poked around the config files under var/etc/openvpn but I cannot find anything that sticks out.

    I think that IPv6 setting is the problem but I could be completely wrong.

    Any help is appreciated.

    Jake



  • I was way off on this one. I use PfBlocker alias function as part of my firewall rules for OpenVPN. PfBlocker was not enabled and that was causing my problem.

    ;)

    Jake