VLAN Issue with x520-da2



  • I got pfsense 2.1 rc0 up and running with my x520-da. It works at about 3gbit when i connect point to point with fibre to another pc (tested with iperf) so it requires some tuning but for my purpose it works

    As soon as i do vlans i stop functioning on the fibre port

    the vlan trunking is setup correctly (previously worked with vmware and otehr units)

    my problem is how do i trouble shoot this.

    i read on the forums to disable VLAN_HWFILTERING but have yet to find out how to do this?

    Any Ideas or Recommendations???



  • What is an x520-da2?

    Please give expanded explanation of "do vlans" (on which box? change what? from what to what?) and "stop functioning on the fibre port" (fire port of what? and what does it no longer do that it used to do?)



  • @wallabybob:

    What is an x520-da2?

    Please give expanded explanation of "do vlans" (on which box? change what? from what to what?) and "stop functioning on the fibre port" (fire port of what? and what does it no longer do that it used to do?)

    Intel X520-DA2 10G Converged Ethernet PCIe Card

    By Do vlans i mean when i set them up and configure them on pfsense. (IE go into vlan set vlan 100 on interface ix0)

    The fibre port works just fine if i give it and ip and connect it to a none trunk configured port or directly to another pc / server.

    I have a dell 5524 with 2 SFP+ Ports one is configured for trunk one is my test port that is on vlan 100 by itself.

    I cannot ping or get dhcp leases when i do 1 (or many) vlans on a single interface. i can get DHCP and Ping when it is not configured as a vlan'd interface

    i am seeing no issues as far as ifconfig is concerned everything looks right.

    I did have this working before as a Virtualized appliance where VMWare handled the vlan side and just presented everything as seperate interfaces. But this didnt work for me because it limited me to 1g of thruput per vlan


  • Rebel Alliance Developer Netgate



  • @jimp:

    http://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Intel_ix.284.29_Cards

    Thank you. I looked at that page yesterday but must of missed that in my haste.

    Thank you very much


  • Rebel Alliance Developer Netgate

    No just good timing :-)

    Check the history, that section didn't exist yesterday.