Trouble with package management



  • Hi,

    Some days ago I updated my 2.1 RC0 installation and after that an interesting defect occurred. choosing some menu item a big red box with HDD image and a text "Packages are currently being reinstalled in the background. Do not make changes in the GUI until this is complete." appears.

    After pressing ok it disappears. But… the problem is that this package reinstallation is a continuos process which lasts forever. I can't modify or add packages even after 24 hours..

    Is some kind of anomaly and what can I do to get rid of it?


  • Banned

    You installed tinc? Reboot once again.



  • it helped! ;D Thanks!


  • Banned

    Well yeah it helps, however not a solution. Still cannot figure out what's the package doing.



  • Is there anything not quite right in the TINC package in 2.1?
    Or anything one must be aware of to make it work?
    I've not used it. 
    I'm considering setting up a net between several distant points for testing but I only know what I've read.


  • Banned

    @kejianshi:

    Is there anything not quite right in the TINC package in 2.1?

    The reinstall is kinda broken, as described above.



  • So, beyond the reinstall process being temporarily glitchy, there are no subtle tricks I need to be aware of to save me 10 days of hair pulling or anything?  Just straight forward setup?  I've got a atom based box coming back here because someone touched it when they shouldn't have.  There will be an opportunity for me to put 2.1 on it and test TINC before I send it back out again.  Thats why I'm asking.


  • Banned

    Well yeah, otherwise it works… just the install is somewhat weird.



  • Had the same problem with tinc earlier. Thanks to Jimp who helped me to get over it.

    In case there is never-ending upgrade happening, just go to 'Diagnostics' >> 'Backup & Restore' and at the bottom of the page click on 'lock all packages' or something like that, and then reinstall broken packages again.


  • Banned

    @zenny:

    In case there is never-ending upgrade happening, just go to 'Diagnostics' >> 'Backup & Restore' and at the bottom of the page click on 'lock all packages' or something like that, and then reinstall broken packages again.

    Well, there are not broken packages. This is an issue specifically with tinc.



  • @doktornotor:

    @zenny:

    In case there is never-ending upgrade happening, just go to 'Diagnostics' >> 'Backup & Restore' and at the bottom of the page click on 'lock all packages' or something like that, and then reinstall broken packages again.

    Well, there are not broken packages. This is an issue specifically with tinc.

    I guess I am also talking about tinc. See this thread: http://forum.pfsense.org/index.php/topic,63889.0.html

    It is not broken in my case. Rolled back to 18 July snapshot as there are some problems with pfBlocker with 25 July. ;-) But tinc upgrade works fine in both snapshots.