Routing issue? Works after reboot



  • Having a problem with one of the sites loosing connection, not sure if the build is the issue, but all 3 location on latest 2.1 build.

    Site A 192.168.1.0/24
    Site B 192.168.5.0/24
    Site C 192.168.0.0/24

    3 sites connected through layer 2 MPLS via telco.  Confirmed it's not the telco dropping since PFSense can ping PFSense even when route not working.

    We switched to PFSense last night, and everything was working fine and all of a sudden Site B lose connection to Site A and A can't reach B, but Site C can still reach site B and vice versa.  After rebooting PFSense at A, everything routing correctly again.  Oh and Site A never looses connection to site C, just B.  Simple setup with static route set for the 3 sites, anybody have suggestion on troubleshooting this?



  • Installed Rip to test, and narrowed it down to the main site A router stopping the routing service.  Randomly the service stopped without any info in the log indicating why.  Tried to start the service under "Status" -> "Services", even though gui says service started, the status still displays stopped and routing does not work till the firewall is rebooted.


  • Rebel Alliance Developer Netgate

    In case others hit this, it was apparently caused by having Captive Portal active on the MPLS interface (an accidental leftover from a previous use of that interface.)



  • thanks jimp, should of caught it but was missed.  cp was originally enabled on the wlan interface, but there may have been a configuration issue that caused some issues so decided to narrow it down.  disabled the wlan interface and guess cp just took over the next interface which was the mpls interface which caused all sorts of problems.  kind of surprised our point to point worked at all but glad it was something simple.


Log in to reply