Devic polling



  • I enabled device polling from the advance menu of the web gui. When I checked sysctl -a I get kern.polling.enable: 0
    how do I know if polling is really working? I have 3 Nics in my pfSense box. 2 use dc driver and 1 use xl driver so I know all support kernel polling.



  • ifconfig -a and look for the polling flag.



  • still dont think its working. I did ifconfig -a didnt see any polling flags whats interesting is what I did next. I enabled kernel polling at shell but I didnt see the polling flag instead I saw it under options for the interfaces. What does this mean?

    ifconfig -a

    dc0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=8 <vlan_mtu>inet 192.168.1.1 netmask 0xffffffc0 broadcast 192.168.1.63
            inet6 fe80::208:a1ff:fe96:5917%dc0 prefixlen 64 scopeid 0x1
            ether 00:08:a1:96:59:17
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    xl0: flags=8802 <broadcast,simplex,multicast>mtu 1500
            options=9 <rxcsum,vlan_mtu>ether 00:50:04:86:c8:3a
            media: Ethernet autoselect (none)
            status: no carrier
    dc1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=8 <vlan_mtu>inet6 fe80::212:17ff:fe42:a2d8%dc1 prefixlen 64 scopeid 0x3
            inet 10.0.70.13 netmask 0xffffff00 broadcast 10.0.70.255
            ether 00:12:17:42:a2:d8
            media: Ethernet autoselect (10baseT/UTP)
            status: active
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
            inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
    pflog0: flags=100 <promisc>mtu 33208
    pfsync0: flags=41 <up,running>mtu 2020
            pfsync: syncdev: lo0 maxupd: 128

    sysctl -n kern.polling.handlers

    0

    sysctl kern.polling.enable=1

    kern.polling.enable: 0 -> 1

    ifconfig -a

    dc0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=48 <vlan_mtu,polling>inet 192.168.1.1 netmask 0xffffffc0 broadcast 192.168.1.63
            inet6 fe80::208:a1ff:fe96:5917%dc0 prefixlen 64 scopeid 0x1
            ether 00:08:a1:96:59:17
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    xl0: flags=8802 <broadcast,simplex,multicast>mtu 1500
            options=49 <rxcsum,vlan_mtu,polling>ether 00:50:04:86:c8:3a
            media: Ethernet autoselect (none)
            status: no carrier
    dc1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=48 <vlan_mtu,polling>inet6 fe80::212:17ff:fe42:a2d8%dc1 prefixlen 64 scopeid 0x3
            inet 10.0.70.13 netmask 0xffffff00 broadcast 10.0.70.255
            ether 00:12:17:42:a2:d8
            media: Ethernet autoselect (10baseT/UTP)
            status: active
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
            inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
    pflog0: flags=100 <promisc>mtu 33208
    pfsync0: flags=41 <up,running>mtu 2020
            pfsync: syncdev: lo0 maxupd: 128

    sysctl -n kern.polling.handlers

    3
    #</up,running></promisc></up,loopback,running,multicast></vlan_mtu,polling></up,broadcast,running,simplex,multicast></rxcsum,vlan_mtu,polling></broadcast,simplex,multicast></full-duplex></vlan_mtu,polling></up,broadcast,running,simplex,multicast></up,running></promisc></up,loopback,running,multicast></vlan_mtu></up,broadcast,running,simplex,multicast></rxcsum,vlan_mtu></broadcast,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast>



  • Did you try rebooting after changing it?  Perhaps its a reboot bug.



  • yeah rebooted twice, still no polling flags on the interfaces. Only when kern.polling.enable is enabled I see polling under options as per my last post.

    Im using 1.0-BETA1-TESTING-SNAPSHOT-2-8-06



  • kern.polling.enable
                Legacy MIB, that was used to enable or disable polling globally.
                Currently if set to 1, polling is enabled on all capable inter-
                faces.  If set to 0, polling is disabled on all interfaces.

    I'll check it out, its possible that I just left out that interface type from the supported list.



  • cool.  8)

    in the mean time I'll just set the option in sysctl.conf since I want to manipulate other polling options as well.



  • Im running the new testing snapshot TESTING-SNAPSHOT-02-15-06. I removed the kern.polling.enable variable from my /etc/sysctl.conf file to see if the web gui option for enabling and disabling polling would work. Well the option didn't work and polling seem to be enabled by default on reboot, even after manually disabling it at shell.





  • :D

    Thanks, thats fix it. Enabling and disabling polling with the web gui now works.


Locked