PFS 2.0.3 and dual PPPoE WAN



  • I have searched the forum, and seen this question asked a couple of times w/out a response, but I figure I'll try again anyway.  I'm an experienced PFS user and absolutely love the product, especially in multi-WAN environments.

    The problem I'm running into now is getting 2 at&t PPPoE modems to auth at the same time.  I'm running 2.0.3 Release on a brand new Intel Atom board w/ 2 GB ram.  I'm using the onboard Intel NIC as my LAN, and have installed an older Intel dual NIC card in the PCI slot for both my PPPoE WANs.  I can always get the WAN connection to authenticate, but never the secondary WAN.  I've tried switching modems, (changing the WAN auth to be the same as the WAN2 auth and plugging the WAN2 modem into the WAN interface) and it will register fine, so it's not a DSL, modem, or credential problem.  I also tried using a USB NIC as my WAN2 with the same results.

    Is there a trick to this that I'm missing?  I can click the "connect" button on the Status >> Interfaces page for WAN2, and it tries to connect, fails to obtain an IP Address, and shuts back down.

    Any help would be greatly appreciated.

    Thanks again for this amazing project!

    -M@



  • So this is one case where just ignoring it for a while worked.  I beat on this thing for HOURS yesterday, and today, but today I just left them both connected, and figured I'd remote in later to bang on it over the primary WAN that was working, and 5 or so hours later, the secondary WAN had authenticated PPP all on it's own.  I'm definitely confused, but if there are any further developments, I'll post them here.

    -M@



  • I would be happy to post in an original thread, if required.

    I am having the exact same problem, except the line is not coming up on its own, not even left for hours.
    On the dashboard, the second WAN just sits there with a giant ugly unhappy red X.
    The first link is green and receives an IP, and if I go into interfaces and select the adapter with a MAC next to it, I can get the second WAN to show green, but it loses the PPPoE credentials; as soon as I re-enter them, the line goes back to red.

    I'm stumped, and I'd be eternally grateful for help.

    Like OP, I am using 2.0.3, and have tried 2.0.1/2, and have even tried different NICs and the order of assignments!

    Thank you.



  • I had the same problem and it turned out to be my ISP. One of the ADSL lines would simply fail to connect PPPoE for several hours.



  • Are you using different monitor IPs for each interface?


Log in to reply