Squid3 - broken tab & non-working state



  • Hi,

    Was playing with Squid3 and Squidguard package, and I need help to clean everything for start again the configuration of the 2 package.

    What was done :

    • installation of "Squid3" package, basic setup listening on 3128 only, usage was OK
    • installation of "Squidguard", setup of the Toulouse dedicated to PfSense blacklist. Install of the database ok, but no categories appears in the configuration tabs. At this point, Squid3 non working.
    • Re-install package, re-install GUI, same problem.
    • Un-install everything + download the .XML full setup & remove by hand all the "Squid" & "Squidguard" reference.

    From this clean state, install only the Squid3 package to start again the setup, but :

    • Tab "Authentication" is broken :
      Fatal error: Cannot use string offset as an array in /usr/local/www/pkg_edit.php(271) : eval()'d code on line 1

    • Squid3 access using port 3128 give :
      ERROR
      The requested URL could not be retrieved

    • I have setup language to "en" for posting here the output error, but the error are still displayed in French (previous setup).

    –> My guess is it didn't setup everything because of old configurations.
    --> And, I think I need to remove everything again, XML clean by hand, but need more "rm -rf /../folder/" to clean my setup ... And I'm stuck here.

    If you need more logs or testing to catch the tab "authenticate" error in Squid 3 package, just please ask.

    Thanks,

    Phil



  • To avoid problems with squid version, use squid3-squidguard package instead of squidguard that has squid2 as dependence.



  • The same here - squid3 is the only package on the system, Authentication tab throws the following message

    Fatal error: Cannot use string offset as an array in /usr/local/www/pkg_edit.php(271) : eval()'d code on line 1 
    

    I'm running pfSense 2.0.3, fresh install. Tried to uninstall all the packages, then installed only squid3.

    Are there any ideas how to fix it?



  • @RubenMuradyan:

    The same here - squid3 is the only package on the system, Authentication tab throws the following message

    Fatal error: Cannot use string offset as an array in /usr/local/www/pkg_edit.php(271) : eval()'d code on line 1 
    

    I'm running pfSense 2.0.3, fresh install. Tried to uninstall all the packages, then installed only squid3.

    Are there any ideas how to fix it?

    Full reinstall solves the issue.



  • Hi,

    I run version 2.0.3. Package list doesn't show me "squid3-squidguard" but only "squidGuard".
    Search engine on the whole forum for keyword "squid3-squidguard" brings me only this thread.

    Is their a second repository to configure ? Or should I move to 2.1-RC release ?

    Thanks for the support  ;).

    Phil


Log in to reply