No traffic when limiter config error



  • We are limiting separate users on a 200Mb fiber connection to certain bandwidths. A colleague of mine had some problems configuring a new limiter, so after messing around with it, up-and-download limiters for a customer ended up with "Queue Size" field set to 500. This worked without problems.
    For the next customer being added to the system, the "Queue Size" field was automatically set to 100. The shaper blocked all traffic for the corresponding FW rule and the error below was logged:

    php: : The command '/sbin/ipfw /tmp/rules.limiter' returned exit code '65', the output was 'Line 50: 2 <= queue size <= 100'
    

    The odd thing was, emptying the "Queue Size" field for the newest limiters did not fix the problem. The error was the same.

    Editing /tmp/rules.limiter with vi showed that line 50 was around pipe 17 (didn't know how to show line numbers in vi and fixing the problem had priority over collecting debugging information)

    [...]
    
    pipe 14 config  bw 10Mb
    
    pipe 15 config  bw 10Mb
    
    pipe 16 config  bw 10Mb
    
    pipe 17 config  bw 50Mb queue 500
    
    pipe 18 config  bw 30Mb queue 500
    
    pipe 19 config  bw 1Mb
    
    pipe 20 config  bw 8Mb
    

    I actually had to remove the "Queue Size" options on limiters (pipe) 17 and 18 to get traffic flowing on pipes 19 and 20.

    Reading the ipfw documentation seems to show that the syntax in the configfile was correct. The pfSense config.xml shows doesn't seem odd either with "<qlimit>500</qlimit>" in the queue sections.

    Now for the question, should I make a bug report for this?
    //Edit: Version 2.0.3-RELEASE (i386)



  • Absolutely. And I can confirm there are issues when setting queue size.

    I did a bug report on a similar issue and just updated it in the bug tracker. But I would prefer if you started a new bug and I can mark mine a dublicate of yours. This since you obviously have much better technical understanding of the pfsense and probably will be better to cooperate with core team to fix it than I ever will.

    My bugreport:
    https://redmine.pfsense.org/issues/2891

    Original forum post:
    http://forum.pfsense.org/index.php/topic,60175.0.html



  • Hello,
    i can confirm that issue, on 2.0.3 A64  :(
    This is an Problem of ipfw, the queue is hardcoded to maximum 100. if you set to an higher value, you get the error message in Systemlog
    I have got an LWL Gbit WAN with an flatrate to 100Mbit, i need to set an Limiter queue to 100Mbit, but with the default setting ( queue 50 ) i can only get ~25Mbits.
    i pushed the queue to maximum 100 now i get ~50Mbits.
    i read in an other Forum, one guy patched the dummynet to an higher value, but the thread was from 2006 or so.

    Is there some one else with that problem ?

    P.S. if i remove the limiter than i will get about 850Mbits running on an i7 QC 3,6 with 8Gb Ram and 3 intel dual Gbit NIC, so no hardware issue is there.

    Greetings



  • Hi CSBS
    Please post a bug report. I have tried but could not back my findings up with fact so it was rejected. Sounds like you have good evidence.

    Else 2.1 final is out… you can try to upgrade if you dare upgrade your production router. Interesting to head if bug exist in 2.1 or if it is solved.


Log in to reply