UPNP



  • I have tried installing the miniupnpd package but it stalls at "Loading configuration". I did not try to check the status of UPNPD before I tried installing it, but when I try to check the status or edit the service I get this error message:

    Fatal error: Cannot redeclare upnp_action() (previously declared in /etc/inc/services.inc:1272) in /usr/local/pkg/miniupnpd.inc on line 13

    Has anyone seen this before? The miniupnpd package is not listed as installed in the packages section.



  • miniUPN is since 1.2 per default included.
    If you get this message it means you already have miniUPNP and are trying to install it again.



  • How do I uninstall it then? I can't get it to register the UPNP service anymore.



  • this forum has a search function.

    @rsw686:

    @PeeZee:

    Hmm, I seem to have the same problem, only worse.

    I was running a 1.0.1 install (very stable for quite a while) and today decided to upgrade to 1.2-RC2.
    Unfortunately I had miniupnp installed on the 1.0.1 install.

    The upgrade went very smooth, but since uPnP is included in the 1.2 release I now had 2 (!) entries in the web gui about upnp (one said upnp from the base install and the other miniupnp from the package)

    Ok, tried removing the package, went smooth, no errors, only the problem now got worse since I still have the 2 web gui entries but now they both point to an error 404…

    Shouldn't there be a big warning somewhere "Remove miniupnp package before upgrading to 1.2" ?

    Backup your config and remove the miniupnpd menu section from the <installedpackages>section. Restore your config. Then reinstall the upgrade to restore the miniupnpd files.</installedpackages>



  • Thank you for your help. For future readers, the package did not show up in the backup file as it never finished installing the package. Reloading the update fixed the problem.


Log in to reply