Problema de acesso do cliente OpenVPN entre as redes



  • Boa tarde amigos, tenho o seguinte cenário e funcionando.

    Matriz: 10.0.0.0/20
    Filial 01: 10.0.20.0/24  Tunnel network: 172.16.0.0./24
    Filial 02: 10.0.34.0/24  Tunnel network: 172.16.1.0./24

    A VPN está fechada e funcionando, de qualquer máquina da filial 01 eu pingo qualquer máquina da filial 02 ou matriz, isso funciona de ambos os lados. Criei no meu servidor na Matriz clientes para a conexão dos usuários que não residem em nenhuma das filiais. Quando o cliente conecta no servidor da matriz ele consegue pingar todos os servidores e serviços da matriz (10.0.0.0), mais não pinga ou acessa nenhum serviço das filiais.

    Tunnel network: 172.16.53.0./27

    Já inclui a configuração na guia avançada, mais não funcionou

    push "route 10.0.0.0 255.255.255.0";
    push "route 10.0.1.0 255.255.255.0";
    push "route 10.16.0.0 255.240.0.0";
    push "route 10.32.0.0 255.240.0.0";
    push "route 10.0.16.0 255.255.240.0";
    push "route 10.0.32.0 255.255.240.0"

    Desde já agradeço a atenção de todos!



  • Nenhuma sugestão?



  • Da matriz vc nao pinga as filiais? é isso?

    tira esse comando "push", deixa somente o route x.x.x.x x.x.x.x;



  • @neo_X:

    Da matriz vc nao pinga as filiais? é isso?

    tira esse comando "push", deixa somente o route x.x.x.x x.x.x.x;

    É o seguinte, conecto a VPN através de um notebook por exemplo, a VPN está sendo fechada com a matriz e pingo todos os servidores da mesma. Mais se eu quiser pingar algum servidor de alguma filial, não funciona. Mais quando estou na matriz com o mesmo notebook, sem fechar VPN é claro, eu consigo pingar todas as filiais.



  • Baloeiro,

    Na configuração avançada das Filiais, coloca a rede 172.16.53.0/27 (clientes PPTP).

    route 172.16.53.0 255.255.255.224;

    Faça o teste.



  • neo_X, tenho o mesmo problema, fiz o que você falou e não vai.

    Poderia me ajudar?

    Obrigado



  • rec, como esta o seu ambiente. Quais os ips, quantas vpns?



  • neo_X, é uma VPN só, servidor matriz e servidor filial.

    Matriz
    LAN: 192.168.0.253
    WAN: IP Fixo

    Filial
    LAN: 192.168.10.253
    WAN: IP Fixo

    Obrigado.



  • Olá rec.br9
    Conseguiu configurar?

    Vi outro tópico que você resolveu o problema.

    http://forum.pfsense.org/index.php/topic,65413.0.html



  • Bom dia, consegui resolver nesta sexta-feira.

    O que eu fiz foi adicionar uma placa de rede no servidor matriz e mais uma no servidor filial, essa placa de rede do servidor matriz recebe a classe de IP do servidor filial e no servidor filial recebe o IP do servidor matriz e mais nada.

    Veja o PING abaixo.

    Mandei pingar do IP 192.168.10.253 (servidor filial) para 192.168.0.231 (AD 2003 atrás do servidor matriz).

    O IP 192.168.0.57 é a placa de rede recém adicionada no servidor filial com IP da classe da matriz 192.168.0.0

    Logo ele sai ping de 192.168.10.253 vai para 192.168.0.57 e redireciona automaticamente pelo túnel

    Veja que lindo … rsrs

    PING 192.168.0.231 (192.168.0.231) from 192.168.0.57: 56 data bytes
    36 bytes from 192.168.0.253: Redirect Host(New addr: 192.168.0.231)
    Vr HL TOS  Len  ID Flg  off TTL Pro  cks      Src      Dst
    4  5  00 0054 a680  0 0000  40  01 51b8 192.168.0.57  192.168.0.231

    Se precisar de ajuda me da um tok..

    Abraço!



  • Que bom que conseguiu.

    Obrigado por compartilhar a informação.


Log in to reply