Traffic shaper only limit the uplink bandwidth



  • Hello i was using zentyal but i decided to change my firewall server to pfsense.

    I have a problem that after finish config the traffic shaper i tried to copy one file using scp for test the connection. But i realize that pfsense is only shaping my uplink connection but not the downlink conection. Somebody knows how to solve this issue.

    Best Regards



  • You're going to have to provide some more information. What does your shaper config look like? What is your up/down speed and what are they set as on the shaper?

    Could be that your downlink speed isn't set correctly. Have you checked your queues to see if the traffic is queueing properly?



  • I configured using the wizard for single lan multiple lan. Maybe i am not doing well. In the Wan Queue en the field bandwith is set the 2mbps that i want for this conection. When i change it to other values it works but only in the downlink.



  • After running the wizard go to the menu "TRaffic shaper" and press "By interface".

    You will probably se all queues listes right under WAN. But under LAN is an extra level. Under LAN there is qInternet that will have your 2Mbitps limit. But there is also a queu next to qInternet that is the default queue with no limit.

    I consider this a bug. Others consider it a setup that is ready to be fine tuned…

    What you shoudl to is uncheck the default in the second queu next to (same level) as qInternet. Then delete that queue. Add the "default" checkmark to another queue under qInternet or add and xtra qDefault under qInternet and give the new qDefault the default checkmark.

    Save. Clear states. Do a speedtest.

    Hopefully you get the right result this time.



  • Thanks a lot it is working right now



  • It's best if you don't use the wizard and manually create the queues to fully understand how it works.


Log in to reply