Ipv6 on WAN via dhcp6 broken after update



  • I have two machines running on snapshots, both to the same ISP.  Both had ipv6 running fine under snaps from around April-June.

    I updated one on 1 Aug and it failed on ipv6 (v4 was fine).  I did the second one and that failed as well.

    Both use DHCP6 on a PPPoE interface.

    An example from the ppp log scraped from the GUI:

    
    Aug 10 00:14:17	ppp: [wan] 0226:2dff:fe24:c201 -> 0203:97ff:fe16:8000
    Aug 10 00:14:17	ppp: [wan] IPV6CP: LayerUp
    Aug 10 00:14:17	ppp: [wan] IPV6CP: state change Ack-Rcvd --> Opened
    Aug 10 00:14:17	ppp: [wan] IPV6CP: SendConfigAck #0
    Aug 10 00:14:17	ppp: [wan] IPV6CP: rec'd Configure Request #0 (Ack-Rcvd)
    
    

    I've just had a look on my PF via ssh and the ppp.log goes back quite a long way so I've scped it to my laptop - actually I've copied out everything under /var/log/

    I've tried messing with the extra options added in the interface config under "DHCP6 client configuration" but I'm well out of my depth and they didn't help.

    Could someone please point me at where to start with debugging this.

    Cheers
    Jon



  • If it's any consolation I have the same issue. The last update to work for me was;

    2.1-RC0 (amd64)
    built on Thu Jul 11 12:37:34 EDT 2013
    FreeBSD 8.3-RELEASE-p8

    All later updates break DHCP6 on the PPPoE interface for me.

    I haven't had time to look at the logs on the broken updates as I need IPv6 to work and so use only the working update.

    Still learning myself but I'll post again when/if I get anything useful

    Cheers
    Jerry



  • Please search before posting.

    You have to tick an option on the interface section of your IPv6 WAN which says 'Use v4 interface for v6'.
    With that it will work again.



  • @ermal:

    Please search before posting.

    You have to tick an option on the interface section of your IPv6 WAN which says 'Use v4 interface for v6'.
    With that it will work again.

    Thanks for that - as it turned out I had tried those extra options but it had "failed" because at some stage I had made a typo in the address I use for gateway monitoring 8(

    Cheers
    Jon


Log in to reply