Help, Old Laptop into router.



  • (Sorry if my English is bad)

    Hardware:

    2wire 4011G (TELMEX ISP)
    Acer Aspire 4315 (Celeron 2.2ghz, 1GB RAM, Atheros WIFI Card, Yukon Marvell Ethernet Controller) ->Running pfsense

    This is what i want to do

    –------------                                              |        |
    Phone Line ->    | 2wire 4011G |  -> Ethernet Cable ->  [Eth Port -Aspire  | ---->  WIFI 
                            --------------                                              |        |

    So, I boot pfSense and assign the interfaces like this:

    WAN (wan) ---> ath0    (Atheros)
    LAN (lan)    ---> msk0    (Yukon Marvell)

    And then i get this:

    Welcome to pfSense 2.0.3-Release-pfSense (i386) on pfSense

    WAN (wan)            -> ath0_wlan0 -> NONE (DCHP)
    LAN  (lan)              -> msk0        -> 192.168.1.1

    So, I hook up a Ethernet cable from the Acer to my Windows PC, open my browser, type in 192.168.1.1, and follow the Webgui Wizard.
    Then set up my WAN (eth0) SSID, WPA2, IP, etc, and then it shows up in my Windows Wireles Networks

    Then  i disconnect the ethernet cable from the Windows computer, and plug it into my 2wire (Wich I configured it as Bridge Mode), then, in my PC i connect to "MobiusOne" (The SSID of pfsense) and it says "No internet access"

    My 2wire sucks even for gaming on LAN, so I  want pfSense to replace it (I've done this before with a Linksys WRT54G running DDWRT) But now i want more power  ;D



  • looks like its waiting to grab an IP from your wireless, assuming you intended to use wireless as "WAN".


  • Netgate Administrator

    You are doing this the wrong way around to fit into your diagram. The WAN should msk0 and LAN ath0. However that will be a problem since you will be unable to connect to the LAN until you've configured the wifi parameters. So to work around this first setup pfSense with only the WAN interface and set it to msk0. Just return past the LAN setup. With only one interface configured pfSense will allow you to connect via the WAN. You will have to do that from a PC connected to the 2wire router. You can then set a firewall rule that to allow access to the webgui from WAN side permanently. Now add the ath0 NIC as LAN. You will now be able to configure the wifi parameters from the WAN side connection and then hopefully connect via wifi. Once that is in place you can disable or remove the rule that allowed access from the WAN side.

    Steve


Log in to reply