Captive portal/WLAN trying to use DNS server on LAN for local domain



  • I've done a thorough search of the forums and played around with things a lot but I'm still not getting anywhere.  Probably a really simple thing but I hope you can help me out.

    I originally set up my LAN in the 192.168.1.1/24 address space with pfSense as DHCP server.  I listed a W2K3 server (192.168.1.2) as my DNS server on the DHCP.  It handles all requests for my local domain (domain.com) and sends all other requests through to pfSense.  So if I type "mail.domain.com" or "domain.com" it resolves from my W2K3 server, but if I typed in pfSense.com my server would forward that on through pfSense to my external DNS.

    I recently set up captive portal on WLAN in the address space 192.168.2.1/24 using pfSense as DHCP server.  I have tried setting the same W2K3 server (192.168.1.2) as the DNS server for WLAN but I ran into two problems:

    1. When I connect to captive portal with 192.168.2.1 listed as DNS, captive portal will not automatically come up
    2. When I type anything ending in "domain.com" I get the login box for pfSense.

    I have allowed traffic from WLAN to LAN and can access the resources of all computers including the W2K3 DNS server by IP address.  DNS does not resolve.

    Ideally, I would like it so that pfSense DHCP clients on WLAN would query my DNS server 192.168.1.2 on LAN to access the network resources.  For instance, on LAN typing "mail.domain.com" resolves to my mail server.  On WLAN, typing "mail.domain.com" resolves to the pfSense login box.  I don't know if this is a function of it being on a different subnet, or what.

    I have played around with DNS forwarder by adding "test.domain.com" to ip 192.168.1.2.  It then resolves.  The problem of doing this is that I would like to use the W2K3 DNS entries, not pfSense, and also that the full address (test.domain.com) not simply "test" needs to be entered to bring up the resource when I have it set up this way.

    Thanks in advance for any help.

    My configuration:

    System: General Setup

    Hostname: firewall
    Domain: domain.com
    DNS servers: None listed
    Allow DNS server list to be overridden by DHCP/PPP on WAN checked

    Interfaces

    WAN PPPoE
    LAN 192.168.1.1/24
    WLAN 192.168.2.1/24

    Services: DHCP Server

    LAN:

    DNS servers: 192.168.1.2

    WLAN:

    DNS servers: (blank)… (but I have tried the W2K3 server on LAN here with the effects mentioned above)


Log in to reply