Captive Portal - Not redirecting to splash page



  • Hi,

    I've been working on getting PFSense to work for a few weeks now, but I am having the same issue every time, with the Captive portal redirection not working.

    I've tried using the Virtual box and full installation on a PC, same result each time.

    So far I have a PC with 2 network cards, 1 plugged into a switch (which is connected to our main modem and the rest of our access points), and the other plugged into a Cisco router with DD-WRT Firmware. When it is setup like this I cannot access the PFSense Web Config, but if I plug both cables into the switch it works fine.

    DNS Forwarding is enabled, Captive Portal is enabled & DHCP is currently being pushed out by our main router (until PFSense is fully functional)

    Can someone give me some help with fixing the Redirection Issue, and how I can configure my LAN port to work when it is directly plugged into my Cisco Router.

    Thanks,
    TheOtherBrit



  • What I can say is that often fails and sometimes redirection becomes too slow.



  • I Was having the same issue on 2.0.1, and I don't think it would be a speed issue


  • Banned

    About time to upgrade.



  • Yeah, I managed to get 2.1 working on Friday, but it hasn't solved the redirection issue

    I Just had a play around with some settings on my router, and I managed to make it so you cannot access the internet unless you login first, but the login is not redirecting to the login page still

    Update: After authentication Redirection URL will not work as well, tried setting it as http://google.co.uk and It will not redirect after login

    Update 2: Just tried pinging a few devices located on the same network and every time I'm getting 100% packet loss, the only thing I can ping is our main router



  • Any help about this issue???



  • I was having similar issues but I read on another post that if you add your DNS server to the allowed IPs then the redirection will work. It worked for me, look under Services->Captive Portal. Choose your zone and click the tab for allowed IP and add your DNS server (probably PfSense). Also be careful with VLANs I am using a untagged vlan on the same NIC that has tagged traffic and this was causing the captive portal to block all traffic for the entire NIC regardless of what VLAN it was on. Jimp has suggested that you don't use untagged traffic on the same interface where you have tagged traffic. I have not had physical access to the network to make the changes to see if this was the issue however the for me was just to add the subnets that were not supposed to be blocked to the allowed IP address tab until I get a change to fix it the correct way.


Log in to reply