PPPoE VDSL Problem



  • Hello,

    first of all sorry for my english. I hope you understand me.

    I have a VDSL internet connection with a static IPv4 address. On this address my provider routes thre little subnets and one large ipv6 subnet.

    In pfsense I set up WAN with pppoe. IPv6 is setup as none.

    My modem is a Allnet ALL500VDSL2 setup in bridge mode (modem mode only). This device set the VLAN Tag 7 for my ISP, so pfsense only need the pppoe connection trough the interface (re0).

    Pfsense is installed on a Watchguard X-Core (nanobsd) 2.1-RC build 15.08.2013. WAN Interface is re0. re0 is connected to the modem on ETH1 (modem has 4 ports) with a normal cat 5e patchcable.

    Now my problem. When I reboot WAN interface shows up but get no ip. Under interface stands 0.0.0.0. If i Disconnect and connect the interface shows up but nothing works.
    If i click disconnect, take off the cable from re0 und put it in again i can connect and get an ip.
    If there is en interrupt auf the connection for example isp modem reset or something else conenction shows up but under interface sthere is ip 0.0.0.0. Reconnect works only if i click disconnect, take off the cable, restart the ALL500VDSL2, put in the cable and click on connect.
    If ip is 0.0.0.0 the ppp logs shows that the pfsense try to reconnect every few seconds.

    So this problem is of course a problem and i looked in this forum. My first try was to setup a delay as descrived in this forum (30 Second loop in interface.inc). This didn't solve the problem.
    Next i tried to append ifconfig re0 down and ifconfig re0 up to ppp-linkdown. This also didn't solve the problem.
    Last I append …pfctl or so -c "interface reload wan" or so i don't remember the correct command. But thsi didn't help.

    I have no idea howto solve this problem. On my device befor (pfsense 2.1-beta with another hardware (IBM-server and hme0 interface)) pppoe works after restart but on interrupt i had to restart pfsense, or wait 3-5minutes, but after restart it worked. The IBM server is damaged so i tried the watchguard.

    Has anyone an idea or fix for me?

    Greetings BJ


  • Netgate Administrator

    @BJXYZ:

    If i Disconnect and connect the interface shows up but nothing works.

    It's not clear to me what happens here. Are you physically removing and reconnecting the ethernet cable? What is the status of the interface after that?

    Steve



  • I have to physically remove and reconnect the cable. Then the Interface shows up and after a few seconds i recive the IP and everything works.

    Sometimes the PPPoE connection losts while normal working. In this case I have to disconnect pppoe, physically remove the cable, restart modem, connect the cable and manuell start ppoe conenction.

    Edit: Oh sorry you meant "If i Disconnect and connect the interface shows up but nothing works."
    Here I click under Interfaces on the Button "Disconnect", the page loads and then I click on the "Connect" Button (Status -> Interfaces [WAN interface (pppoe0)])



  • Any idea for my problem?



  • No idea.

    You might contemplate to setup the ALL500VDSL2 as a router and define pfSense as Exposed Host (usually called DMZ in low-cost routers). You'll have double-NAT, which might impact Dynamic DNS.

    Have you tried 2.0.3? I have one production system running PPoE via VLAN7 on 2.0.3 perfactly. In my case, the modem is totally dumb, and pfSense does VLAN7 tagging. Quite simple to setup, actually. Also has the benefit that pfSense could handle VLAN8, should I ever feel the questionable urge to set up "Entertain" IP TV…


  • Netgate Administrator

    Ok, I just read your edit.

    So there are three forms of disconnect here. The disconnect/connect button in Status: Interfaces: just kills and remakes the ppp session. That though relies on the underlying ethernet connection being present. At the very low level you can physically disconnect the cable and reonnect it. That obviously forces a renegotiation on every level of the connection. There is a third level you can try. At the console (serial or SSH) try issuing:

    ifconfig re0 down
    

    and then

    ifconfig re0 up
    

    Does that re-establish the connection without having to physically disconnect the cable?

    Steve



  • You can try to force the connection between your pfSense box and your VDSL modem to something like 100 / full duplex. I had various random troubles with my VDSL modem (Huawei brand) that were fixed only by forcing the link parameters.



  • @stephenw10

    Thank you for your replay. Pfsense 2.1-BETA hadn't this problem on my old IBM server but it was an hme interface, now it is an re interface. As i described i have tested to append ifconfig re0 down / up to the ppp-linkdown script with no luck. The problem wasn't solved. But I can try it manually.

    @bkraptor

    Okay. At the moment the line is up because i have no auto-reconnect. On the next connection problem i give it a try. Thank you.

    –-

    I will replay if I tested both solutions and give you a feedback.



  • Okay I had an disconnect. I tired ifconfig re0 down / up. But nothing happens. I tried all the tricks I've tried before but with no solution. It takes 30 Minutes after the connection works again. Attached the ppp log. The Auth Error could be because I reset the password. In the 30 Minutes I have often click connect / disconnect and plug in/out the ethernet cable. Perhaps the problem could be the connection timeout?

    @bkraptor How can I set the interface to 100 / full duplex? At the moment auto is set to 100 / full duplex.

    ppp-log.txt



  • If the modem was a Speedport, I'd suspect the power supply's filtering capacitor…this leads to flaky connections, not failing vompletely, but giving issues with dropped packets.

    Okay, no smoking Speedport here, but...did you check if your ALL500VDSL2 is running the latest firmware? Early modely appear to have had issues with dropped packets (at least that's what I've been told, I've no personal experience with that model).

    Sometimes "almost flaky" network hardware gets "really flaky" when connected to Realtek NICs. In that respect I had personal experience, needed to unplug network cables when the Realtek NICs stalled. Solved that issue with a driver update...


  • Netgate Administrator

    Ah, yes I did read that and then forgot.  :-[

    It could well be an auto-negotiation probem between the Realtek NIC and the modem. One of them giving up too early or starting too late for example. Setting the Realtek to forced 100Mbps FD could help. Initially you can set it with ifconfig and see how that work out. To make it stick across a reboot requires some further changes but can be done.

    http://doc.pfsense.org/index.php/Forcing_Interface_Speed_or_Duplex_Settings

    Steve



  • @Klaws
    Thank you for your post. ALL500VDSL2 run on the latest firmware. But Allnet has a new ALL500VDSL2 Rev2 Router, perhaps its a hardware problem of the modem. But with the old Firewall (IBM Server) this problem wasn't there. It could be that the modem is damaged as I changed the Firewall but i don't think so. Perhaps its a driver problem. Is there an howto about upgrading realtek driver?

    @stephenw10
    I will give it a try. Thanks.

    –-
    My other idea is to setup a router infront of the pfsense. I have an wlan-router with dd-wrt firmware. Perhaps this could establish the connection and route the ips to the pfsense (no nat). I wrote an mail to my isp if they give me 2 additional ips (/30 subnet). I allready tried to use the ALL500VDSL2 as a router but there are no ipv6 options and some people wrote that the pppoe connection sometimes disconnect for a few minutes, but im modem mode not.


    UPDATE:
    I've called ALLNET. They told me that the ALL500VDSL2 is a cheap and not realy good device. Perhaps the temperature is too hot and i should place the modem at a other location (at the moment on first he in a rack, should be setup at the bottom of the rack). But they say i should buy the ALL126AS2 this is a good vdsl2 modem with an infineon chip. Bevore i buy this perhaps you can tell me a good VDSL2 Modem wich allready run with a realtek interface?



  • Any idea for a good VDSL2 Modem which works with pfsense 2.1-RC and realtek interfaces?



  • I have bought a Saphairon Speedlink 1113 and now everything is working fine. If I reboot pfsense or the modem pppoe is reconnecting directly.


Log in to reply