Install on a Hard Drive stops at Welcome to pfSense when booting…



  • I have a Netgate FW-7541. I am trying to setup 2.0.3 on a hard drive. I followed this guide:
    http://doc.pfsense.org/index.php/Full_install_on_Netgate_Hamakua
    to the letter, doing the install with a laptop booted off a CD running pfSense-LiveCD-2.0.3-RELEASE-amd64.iso.gz. I changed the fstab and all seems well.

    I install the drive in the unit and when it boots, it gets to the Welcome to pfSense screen, counts down from 3 and stays at zero. I can only administer and watch things on the Netgate through the console, and when I press 1 or any other choice at the above menu, nothing happens.

    Any idea why it does not continue to boot up past that screen?

    I have tried a quick and custom install on several different drives. They all stop at the same place.

    Edit - I also tried installing it on the HD using both different kernels. The embedded kernel didn't even boot.

    Help!


  • Rebel Alliance Developer Netgate

    Are you watching the 7541 boot via the serial console or via the VGA add-on connector?

    You might try the serial memstick installer with the drive still in the 7451 to see if that works better for you. Using that, you should not have to swap the drive around.



  • I am using the serial console through telnet to watch it as it boots. I ordered the vga connector but that won't be here for days.

    Is the serial memstick installer the same as using a usb flash drive installer connected to the 7541? I made a flash drive installer I could try.

    Thanks for your input!


  • Rebel Alliance Developer Netgate

    The serial memstick is the same as the memstick, but it runs over the serial console not VGA.

    The memstick and the ISO behave identically, so you can boot+install from the serial memstick over the serial console.

    I've done that on my net6501, and I believe we've had people here do that on the 7541 as well, but  I don't have immediate access to one of those.



  • Well, I tried 2 different memstick serial versions. 2.0.3 and the latest snapshot 2.1 RC build.

    Both started up and then just kept blinking _  and would not go any further.

    I guess I need to wait until the vga cable arrives, and I'll try it again.

    Weird…



  • One last thought.

    I was supposed to be booting with the memstick plugged into the USB port on the Netgate unit, correct?


  • Rebel Alliance Developer Netgate

    Yes, that's correct.

    Where did the memstick images stop?

    If you have another pfSense box handy, you might try this modification to the memstick:
    http://doc.pfsense.org/index.php/Embedded_install_on_Netgate_Hamakua



  • It looked like this:

    F1  pfSense
    F5  Drive 1

    F5  _

    And the underscore would just blink occasionally.

    F1 is the HD



  • Jimp,

    I tried the Embedded install on Netgate Hamakua mod on the memstick as well as th HD separately. Neither worked. The memstick still won't boot, and I rebuilt it with several different versions.

    Do you have any idea why the hard drive boots when installed, but stops at the menu screen with 8 options and the terminal won't accept any input to make it continue?

    The vga cable is due here wed. I'll make a vga memstick and hope that works unless you can thing of anything else to try.

    Thanks for all your help!!


  • Rebel Alliance Developer Netgate

    That's usually where it switches from VGA to serial output when the serial console is enabled.

    I didn't mean from that post that you should use NanoBSD, but rather that you should use the boot0cfg command on that page to set a special boot sector flag on the drive.

    If all else fails, use a 7541 image from here: http://www.netgate.com/firmware/2.0.3p1-RELEASE-rebrand/



  • I did the mod, not install the Nano.

    I just tried the 386 version and still no hard drive pfSense lovin.  >:(

    Can those nanobsd builds be installed on a hard drive?

    Thanks again.



  • Interesting news. I made an image of the CF card that came installed from Netgate and I installed that on the HD.

    Instant success!

    They must have a special build going on there.

    It still would be nice to do a regular install though. I'm going to see if I can get a build from Netgate.


Log in to reply