Erro de certificado de segurança no Internet Explorer 10 - Squidguard transparen



  • Boa tarde,

    Configurei o PFsense com o proxy transparente e com a lista de bloqueios do squidguard, quando configuro as blacklist para bloquear o que eu quero, alguns sites no Internet Explorer dão erro de certificado de segurança, sites como o Google, Terra, Uol e Outros. Esse erro só dá no Internet Explorer no Chrome ou Firefox por exemplo, funciona normalmente e com as regras que criei no squidguard, o que preciso fazer para funcionar o Internet Explorer sem erro de certificado de segurança?

    Obrigado.



  • Já atualizou os certificados raiz do seu Windows?

    Qual versão do squid você está usando?



  • Então já atualizei os certificados raiz do navegador e também nada, quando desinsta-lo o Squidguard funciona normalmente e a versão do squid é a padrão que é sugerida a 2.7 se não me engado. O erro de certificado só da nos sites do Terra, Google e outros portais. Desmarquei a opção de verificar a revogação dos certificados do servidor mas também nada.

    Nos outros navegadores funciona normalmente só no internet explorer que dá erro de certificado de segunça.
    Ai clico para continuar mesmo assim ai na URL aparece o ip do servidor proxy 10.0.0.1 e mostra um erro de bloqueio de paginas só que nas blacklists do squidguard eu não bloquei nada deixei tudo configurado allow e fiz tudo de acordo com o que ensinam nos vídeos, agora não sei se tem que redirecionar alguma porta pra porta 3128 ou coisa assim do tipo.

    Abraços.



  • E ai pessoal, alguma surgestão ai?



  • Boa noite, pessoal! Durante esses dias de problemas com o Squidguard em relação ao internet eplorer 7, 8, 9 e 10. Resolvi o problema tentando entender os porques! Já que não houve muitas sugestões, vou deixar a solução que resolveu pra mim no meu caso e testei em vários computadores e outros métodos de autenticação: Porta WAN em bridge, DHCP e estático; o caso era o seguinte colocava em modo transparente e o internet explorer dava erro de certificado de segurança, ai beleza colocava com autenticação de usuário local mesmo pra não dar aquele trabalho todo de configurar LDAP e mexer com AD. Funcionava que uma beleza, mas eu precisa de ser configurado transparente pois tem empresas que funcionários que tem privilégios trocam senha de usuário para liberar acesso total aos outros que não tem privilégios. Pra resolver esse caso fiz o seguinte, entrei no erro de certificado e instalei o bendito que pedia no erro do navegador, instalei bom demais, abriu a página do google ohh céus abriu! Mas pensei comigo, vou ter que instalar o certificado em todas as máquinas eu pensei são em média 50 máquinas preciso resolver isso logo, entrei na guia avançado vi lá o web configurator marcado usar HTTPS e utilizar SSL certificate, entrei na guia certificado e confirmei que o certificado que ele usa é o bendito web configurator default, está bem vamos testar, vamos configurar para usar porta 80 (HTTP), alterei e esperei aqueles 20 segundos e funcionou, beleza matei a charada ai entrei no site da hotmail, deu o erro de certificado, mais abria quando clicava em continuar assim mesmo. Então eu pensei no firewall e nos proxy não tem muita coisa pra alterar já ta funcionando então fui em opções da internet, conteudo, certificados, avançado… e tinha uma guia com finalidade do certificado beleuza creuza, estava várias opções relacionada a navegação desmarcadas então revisei tudo que eu precisava e marquei cada opção que acabou sendo todas pois tudo ali era importante (as vezes vários erros de certificados que encontramos pode estar a solução relacionado nesse caminho). Apaguei todo histórico do navegar e fiz os testes funcionou belezinha, sem problemas, com os grupos de bloqueios do squidguard bloqueando pornografia e tudo mais que não é do uso da empresa, até que: Mudei de navegador e deu problemas novamente, ai estava cansado, com a sinusite me matando, eu pensei já era, mas ai veio a solução, na guia advanced tem uma opção disable HTTP_REFERER enforcement check, marquei essa opção que não sei muito bem o que é li e reli não entendi direito, reiniciei o servidor depois de tanta alteração ele inicio todos os processos e funcionou 100% e resolveu meu problema. Espero que com esse depoimento maluco e cheio de erros de Português, sirva para ajudar alguém que venha encontrar esse problema pela frente. Trabalho com linux algum tempo já na área de segurança, quando conheci o PFsense achei fantástico porque substitui muitos arquivos conf e seu trabalho é mesmo desgastante, não é preciso editar um arquivos com milhares de linhas de comando. Eu estou satisfeito com o sistema vou divulgar e contribuir para melhorar mais e mais! Obrigado a todos do forum.


Log in to reply