VoIP traffic shaping - no drops but choppy sound



  • Hi,
    I am trying to set up traffic shaping for voip. I have set up an alias for voip traffic ( asterisk server as well as remote wan servers ) and run the wizard. All voip traffic hits the VoIP queues as expected. Sound is perfect when there only is traffic in the VoIP up/down queues. But as soon as a start a download or just hit som web pages, the sound gets choppy.

    I have no drops in any queues according to the graphs, and no additional traffic is assigned to the voip queues while adding the extra download/web traffic. I have set the bandwidth limits at approx. 80% of the real limits.

    I can't detect any noticeable difference when I turn shaping on/off, so I am a little confused.

    What am I missing or what could be going on here?

    I am running pfsense 1.2-BETA-2.
    Thanks,
    /Lars



  • IT might help to know what hardware you are using for the pfsense machine.

    gm…



  • This is the hardware I run pfSense on:

    • SERVER: IBM eServer x100 P4/3.0 2MB 512/80GB machine.
    • WAN:Build in network interface.
    • LAN: Netgear FA311 card.

    The ADSL is connected via a Cisco 800 Series router.
    /Lars



  • I am having similar issues and would like to know if you've had any luck resolving.  We switched from a microwave T1 link (1.5Mbps up and down) to a copper-based T1.  Whereas the outgoing portion of the conversation was an issue with the microwave link, now the problem is the incoming portion of the call.  When there is no additional traffic, everything is peachy.  Once someone starts a download or other traffic kicks in, though, the call quality tanks.  No dropped packets, but choppy as all get-out.  Very annoying.  Have tried configuring traffic shaping multiple ways, but there is not (that I've found) a whole lot of useful documentation on doing this.  Any help would be greatly appreciated.

    Thanks!



  • With VoIP, it's always good to try this if you're having problems.
    http://doc.pfsense.org/index.php/Static_Port



  • Intriguing. I don't have any problems with VoIP perse, but it could be better. Let's see what that setting does.



  • Assuming these are Internet connections, or some other type where you don't control what's on the other side, you are probably attempting to shape traffic after you've already received it from your upstream router. Very little can be done to improve quality in this case.



  • Hi again,

    CMB:
    Static port did nothing for me, unfortunately.

    ddimick:
    This is what I have been suspecting as well ( shaping after already received). All though, We are currently running IPCop and have not nearly the same choppiness problems with incoming VoIP there. I'm evaluating pfSense after reading mainly on the Trixbox forums, realizing a lot of people like it so much because of its VoIP traffic shaping features. But I guess all environments are unique…

    /Lars



  • I am having the same problem here.  Its has been very frustrating to try to get my shaping down to the point to where my voip calls going through the queues correctly but, when someone browses the internet my call quality goes to the dumps.

    There is no drops in my voip queues but there are certainly drops in my other queues which is what I read is what I want.

    So why is it that my queues are correct but my call quality is poor when other internet services are running?

    I have plenty of bandwidth for this an SDSL 1.5/1.5 with me assigning a max bandwidth of 1.0/1.0?



  • What you're likely experiencing is network jitter.  VOIP is realtime transmission so even when all traffic arrives you'll hear moments of silence (choppy sound) as codec is trying to compensate for data which is not there yet.  Some codecs handle jitter better than other so you might want to try a different codec.


Log in to reply