2.1-RC1 (i386) very high CPU usage



  • Not sure whether anyone else has noticed, but there appears to be an abnormally high CPU utilization % since upgrading from 2.1-RC0 to 2.1-RC1.  On my Supermicro mini-itx system X7SPA-HF it is pegged around 99-100% whereas it rarely used to exceed 50% during spikes.  Is there any way to quickly identify which process is pegging the CPU?


  • Rebel Alliance Developer Netgate

    It's not a general issue that we've seen. It would help to know the exact snapshot you're on.

    To see the process usage, use top -aSH from the shell, or Diagnostics > System Activity



  • Thanks Jimp.  I'm currently only 2.1-RC1 Built On: Tue Aug 20 13:38:38 EDT 2013.

    It appears check_reload_status is biggest CPU hog currently

    PID USERNAME PRI NICE  SIZE    RES STATE  C  TIME  WCPU COMMAND
      258 root    138  20  3352K  1176K CPU3    3 415:01 100.00% /usr/local/sbin/check_reload_status
    92766 root      76  20 90132K 34820K piperd  1  0:01 73.97% /usr/local/bin/php -f /etc/rc.start_package
    92126 root      76  20 85012K 27744K lockf  2  0:01 69.38% /usr/local/bin/php -f /etc/rc.filter_config
    93626 root      71  20  6280K  6300K select  1  0:00 52.88% /usr/local/bin/ntpd -g -c /var/etc/ntpd.con
      11 root    171 ki31    0K    32K RUN    1 567:21 41.89% [idle{idle: cpu1}]
    75478 root      72  20  5432K  3644K select  0  0:00 37.70% /usr/local/sbin/openvpn –config /var/etc/o
    67944 root      76  20 85012K 27744K lockf  2  0:00 32.76% /usr/local/bin/php -f /etc/rc.filter_config
    96764 root    123  20  238M 38796K CPU0    0  0:02 32.18% /usr/pbi/snort-i386/bin/snort -R 60243 -D -
      11 root    171 ki31    0K    32K RUN    0 575:23 28.47% [idle{idle: cpu0}]
    31395 root      76  20 85012K 27744K lockf  1  0:01 17.58% /usr/local/bin/php -f /etc/rc.filter_config
    72019 root    119  20 92180K 36748K CPU2    2  0:03 16.46% /usr/local/bin/php -f /etc/rc.start_package
    96109 root      76  20  3644K  1324K wait    0  0:00 14.16% /bin/sh /usr/local/etc/rc.d/snort.sh start
    43424 root    118  20 90132K 35276K RUN    1  0:02  9.28% /usr/local/bin/php -f /etc/rc.filter_config
    70230 root      76  20 85012K 27744K lockf  2  0:01  8.59% /usr/local/bin/php -f /etc/rc.filter_config
    55343 root      66  20  354M 94484K bpf    1  0:01  7.67% /usr/pbi/snort-i386/bin/snort -R 60243 -D -
    86031 proxy    71  20 18548K  8652K kqread  0  0:00  7.67% (squid) -D (squid){initial thread}
    86223 proxy    76  20  1512K  728K piperd  0  0:00  7.57% (unlinkd) (unlinkd)
    86031 proxy    76  20 18548K  8652K ucond  1  0:00  7.57% (squid) -D (squid){squid}


  • Rebel Alliance Developer Netgate

    Check your system logs, something must be generating a bunch of interface down/up events



  • @jimp:

    Check your system logs, something must be generating a bunch of interface down/up events

    Thanks Jimp!  I went ahead and updated to the latest build and re-installed bandwidthd and it appeared to settle the box down.  So far so good!



  • OK - I spoke too soon.  It appears this check_reload_status is back again.  It kicked in overnight.

    PID USERNAME PRI NICE  SIZE    RES STATE  C  TIME  WCPU COMMAND
      262 root    136  20  3352K  1176K CPU3    3 714:13 84.77% /usr/local/sbin/check_reload_status
    68867 root    133  20    0K    8K CPU2    0  0:21 80.57% [snort]
    92322 root      76  20 85012K 27740K lockf  1  0:01 77.49% /usr/local/bin/php -f /etc/rc.filter_config
    92615 root      76  20  3368K  1248K piperd  2  0:00 52.98% [awk]
    91998 root      76  20  3644K  1252K wait    0  0:00 52.69% [sh]
    92569 root      76  20  3264K  928K wait    1  0:00 52.69% [xargs]

    Seems like squid may not have installed correctly during the firmware update.  Is there any way to manually remove squid but still preserve the settings for when it's reinstalled?  When I uninstlal squid via the packages menu, it still appears as  stopped service on the homepage.

    Aug 22 09:24:02 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:24:02 kernel: em3: promiscuous mode enabled
    Aug 22 09:24:02 php: rc.start_packages: The command '/usr/local/etc/rc.d/bandwidthd.sh stop' returned exit code '1', the output was 'No matching processes were found'
    Aug 22 09:24:01 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:24:00 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:24:00 ntop[71511]: THREADMGMT[t685773120]: ntop RUNSTATE: INIT(2)
    Aug 22 09:24:00 kernel: em3: promiscuous mode disabled
    Aug 22 09:24:00 ntop[71511]: THREADMGMT[t685773120]: ntop RUNSTATE: PREINIT(1)
    Aug 22 09:24:00 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:23:59 php: rc.start_packages: Not calling package sync code for dependency squid of squid because some include files are missing.
    Aug 22 09:23:59 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:23:58 php: rc.start_packages: Reloading Squid for configuration sync
    Aug 22 09:23:57 squid[55932]: Squid Parent: child process 56393 started
    Aug 22 09:23:57 php: rc.start_packages: Starting Squid


Log in to reply