[TUTORIAL] pfSense com PPPOE



  • Olá amigos, boa tarde!!

    É com muita satisfação que venho colocaborar com a comunidade! Tem dois dias que estou igual a um louco tentando correr atrás de informações de como fazer o pfSense funcionar com PPPOE.

    Antes de tudo, li aqui mesmo na comunidade que existe uma falha com os modens onde o mesmo pode ser invadido e o invasor pode colocar o DNS falso e roubar até informações de banco. Por isso, peço conselhos dos mais esclarecidos que eu para informar se este procedimento está correto ou não.

    Minha estrutura está assim:

    1 modem ADSL, um roteador TPLINK, 1 máquina com 2 placas de rede onde está instalado o pfSense e 1 computador para poder configurar o pfsense.

    O cabo do modem será a WAN
    O cabo do roteador será minha LAN e deverá estar ligado na porta LAN do roteador, pois somente dessa forma você conseguirá acessar as configurações do modem.

    Meu modem está distribuindo ip via DHCP. O roteador está estático, desabilitei o DHCP dele pois quero que o pfSense faça isso por mim.

    Ao configurar o pfsense, devo setar na minha LAN a mesma faixa de IP do meu roteador, não sei se é sempre, mas nas 3 vezes em que eu resetei o pfSense a LAN veio como 192.168.1.1, então eu mudei para 192.168.0.1 (que é a faixa de IP do meu roteador).

    Até então estamos assim:

    MODEM: DHCP
    Roteador: 192.168.0.2
    pfSense: 192.168.0.1

    Como o pfSense não está configurado ainda, pode-se colocar um IP manual na mesma faixa nas configurações de rede da máquina que será a cliente onde será configurado o pfSense.

    Máquina: 192.168.0.3

    Agora eu consigo acessar o pfsense pelo IP 192.168.0.1

    Um passo importante: Neste momento é crucial rotear o modem, só funcionou assim. Antes de configurar o pfsense deve-se rotear o modem.

    Com o modem roteador, podemos acessar o painel de configuração do pfsense.

    Como será o primeiro acesso, basta seguir o wizard. ao chegar nas configurações de "Configure WAN Interface" escolha PPPOE e coloque as mesmas configurações que foram colocadas no modem.

    Clique em next em tudo e pronto, pfsense discando como pppoe.

    note que, no servidor, a placa da WAN que mostrava como re1(que no caso eu escolhe nas configurações) e mostrava o IP do modem, agora mostra PPPOE e um IP válido. E após isso, não consegui acessar mais o modem pelo ip dele.

    Solicito aos amigos mais experientes que digam se está correto isso. se dessa forma vai ter alguma brecha para invasão.

    Acredito que o modem está protegido pois o pfsense nesse momento está discando e o modem atuado apenas como bridge.

    Espero ter ajudado alguém que esteja infretando a mesma dificuldade que eu.

    Felippi Cunegundes Laender



  • Legal seu tópico.
    Algumas perguntas que você não especificou acima:

    1- Quem é seu provedor de Internet? GVT, Vivo, Net, outra (qual)?
    2- Qual o modelo do modem?
    3- Por que você já não deixou o modem em bridge antes de instalar o pfSense?

    Observações:

    Se você tivesse configurado o modem em bridge desde o início, teria evitado alguns passos desnecessários.

    Quanto a questão da vulnerabilidade do modem, se este modem não está naquela lista, não vejo por que seria brecha para invasão. Se está, não seria questão de patch - se existir - ou trocar de modem?



  • É bom lembrar que para publicação de tutoriais e dicas temos o blog da comunidade brasileira: http://www.pfsense-br.org/blog/

    É uma pena que pouca gente participe dele. Particularmente acho legal as pessoas publicarem seus tutoriais em seus próprios repositórios ou até mesmo aqui, diretamente no fórum, mas poderiam gerar um post curto fazendo uma chamada ao artigo original no blog da comunidade.

    Criaríamos um ponto de aglomeração de documentação gerada pela comunidade nacional! ;)

    E não tem folclore… basta se cadastrar no blog e começar a postar!

    Abraços!
    Jack



  • @johnnybe:

    Legal seu tópico.
    Algumas perguntas que você não especificou acima:

    1- Quem é seu provedor de Internet? GVT, Vivo, Net, outra (qual)?
    2- Qual o modelo do modem?
    3- Por que você já não deixou o modem em bridge antes de instalar o pfSense?

    Observações:

    Se você tivesse configurado o modem em bridge desde o início, teria evitado alguns passos desnecessários.

    Quanto a questão da vulnerabilidade do modem, se este modem não está naquela lista, não vejo por que seria brecha para invasão. Se está, não seria questão de patch - se existir - ou trocar de modem?

    Meu provedor é OI
    O meu modem é um D-Link DSL-500B
    Sim, eu resetei o modem e deixei em bridge, não funfou.

    Obrigado pelo retorno. Ai que tá, Eu estou tentanto evitar o máximo possível as brechas. neste caso, após feito a configuração, não é possível acessar mais o modem (ao menos eu não consegui).



  • @JackL:

    É bom lembrar que para publicação de tutoriais e dicas temos o blog da comunidade brasileira: http://www.pfsense-br.org/blog/

    É uma pena que pouca gente participe dele. Particularmente acho legal as pessoas publicarem seus tutoriais em seus próprios repositórios ou até mesmo aqui, diretamente no fórum, mas poderiam gerar um post curto fazendo uma chamada ao artigo original no blog da comunidade.

    Criaríamos um ponto de aglomeração de documentação gerada pela comunidade nacional! ;)

    E não tem folclore… basta se cadastrar no blog e começar a postar!

    Abraços!
    Jack

    Jack, obrigado pelo retorno. Eu vou postar. fiz o cadastro e vou colocar o tutorial lá!



  • @JackL:

    É bom lembrar que para publicação de tutoriais e dicas temos o blog da comunidade brasileira: http://www.pfsense-br.org/blog/

    É uma pena que pouca gente participe dele. Particularmente acho legal as pessoas publicarem seus tutoriais em seus próprios repositórios ou até mesmo aqui, diretamente no fórum, mas poderiam gerar um post curto fazendo uma chamada ao artigo original no blog da comunidade.

    Criaríamos um ponto de aglomeração de documentação gerada pela comunidade nacional! ;)

    E não tem folclore… basta se cadastrar no blog e começar a postar!

    Eis o ponto:

    Comecei um Blog com outros colaboradores sobre o pfSense - principalmente - poucos meses antes da sua iniciativa, JackL. Você bem sabe.

    No fim das contas, praticamente fiquei solitário alimentando e administrando o Blog.
    Quisera eu ter conhecido você um pouco antes, naquela época.

    Uma coisa é certa: Se algum dia, seja por que razão, eu desistir de alimentar/administrar meu blog, cada tutorial e/ou notas e artigos irei passar integralmente para o blog da comunidade, desde que você concorde. Pelo menos aqueles que eu publiquei, não tenha dúvida.



  • @johnnybe:

    Uma coisa é certa: Se algum dia, seja por que razão, eu desistir de alimentar/administrar meu blog, cada tutorial e/ou notas e artigos irei passar integralmente para o blog da comunidade, desde que você concorde. Pelo menos aqueles que eu publiquei, não tenha dúvida.

    Buenas Johnny!

    Veja… o blog não é meu. É da comunidade (nosso).

    Simplesmente 'tento fazer' (com o tempo cada vez mais escasso, infelizmente) a moderação do mesmo. Ele está na verdade bem largado Johnny! :(

    Aliás, neste sentido, se houverem voluntários aqui para revisão/moderação de posts no blog, por favor, fiquem à vontade para iniciar imediatamente os trabalhos! :D

    Não se candidata (novamente) Johnny?!? :)

    Os teus posts/tutoriais seriam mto bem-vindos. A ideia do blog da comunidade era exatamente esta - centralizar as publicações ou ao menos as chamadas para elas. Isso facilitaria a vida de todos. Sou da opinião que somar é sempre melhor que dividir esforços!

    Se quiseres fazer um ou mais posts por lá, ao menos fazendo chamadas e apontando para os textos originais, certamente as contribuições serão muito bem-vindas! ;)

    Abraços!
    Jack



  • @JackL:

    Não se candidata (novamente) Johnny?!? :)

    Os teus posts/tutoriais seriam mto bem-vindos.

    Falta tempo, Jack!
    E, mais uma vez, obrigado pela consideração.



  • @johnnybe:

    Falta tempo, Jack!

    Eis o grande problema.

    Na prática, este é um problema crônico. Quem quer colaborar e é motivado a fazê-lo, normalmente são os mesmos que tem menos tempo.

    Os que tem tempo, não tem motivação ou simplesmente não querem colaborar!  :-\

    Abraços!
    Jack



  • @JackL:

    Os que tem tempo, não tem motivação ou simplesmente não querem colaborar!  :-\

    Perfeitamente! Já é difícil obter um mínimo de feedback, imagine colaborar? A grande maioria tem por intenção única sugar as informações!  :(



  • @johnnybe:

    A grande maioria tem por intenção única sugar as informações!  :(

    Bem, você sabe que compartilho desta mesma opinião Johnny!

    Confesso que este, é um dos motivos (além da extrema falta de tempo, claro), de eu ter me afastado um pouco aqui do fórum nos últimos tempos. :-[

    Abraços!
    Jack


Log in to reply