[Resolvido] Problema no pacote squid3



  • Prezados,

    Instalei aqui uma máquina virtual usando a imagem pfSense-LiveCD-2.0.3-RELEASE-amd64-20130412-1027.iso.
    Após instalar, entrei na GUI, configurei um servidor de autenticação LDAP, testei em Diagnostics->Authentication e funcionou.
    Mandei instalar o squid3, instalou sem erros.
    Só fiz isso.
    Quando entro na configuração do proxy server, ao clicar na aba autenticação, aparece o seguinte erro.

    Fatal error: Cannot use string offset as an array in /usr/local/www/pkg_edit.php(271) : eval()'d code on line 1
    

    Alguém pode me ajudar?
    Vi aqui no fórum mesmo um problema com o mesmo, mas estava relacionado à ordem de instalação do SquidGuard/Squid3, e eu não instalei SquidGuard (vou testar o Dansguardian), instalei somente o Squid3.



  • Bom,

    Podem fechar o topic, não sei porque mas agora abriu a aba de configuração.



  • @broonu:

    Bom,

    Podem fechar o topic, não sei porque mas agora abriu a aba de configuração.

    É muito difícil algum moderador trancar (fechar) algum tópico, só em casos especiais.
    O que eu peço a você é: Edite o Subject (Assunto) de seu tópico e coloque [resolvido].  :)



  • @johnnybe:

    @broonu:

    Bom,

    Podem fechar o topic, não sei porque mas agora abriu a aba de configuração.

    É muito difícil algum moderador trancar (fechar) algum tópico, só em casos especiais.
    O que eu peço a você é: Edite o Subject (Assunto) de seu tópico e coloque [resolvido].  :)

    Obrigado pela informação amigo.



  • Obrigado eu.  8)



  • Na verdade agora estou com problema pra usar Squid3/Dansguardian.

    Eu vi que o Marcello recomenda instalar Squid3 depois de instalar Squidguard/Dansguardian, mas aqui pra mim não resolveu.
    O Dansguardian instala o squid 2.7 por cima, e mesmo eu reinstalando o Squid 3, não funciona.

    [2.0.3-RELEASE][admin@gateway]/root(6): /usr/local/sbin/squid -v
    Squid Cache: Version 2.7.STABLE9
    configure options:  '--bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/var/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--enable-auth=basic digest negotiate ntlm' '--enable-basic-auth-helpers=DB NCSA PAM MSNT SMB LDAP SASL YP' '--enable-digest-auth-helpers=password ldap' '--enable-external-acl-helpers=ip_user session unix_group wbinfo_group ldap_group' '--enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--with-pthreads' '--enable-storeio=ufs diskd null aufs coss' '--enable-delay-pools' '--enable-snmp' '--enable-ssl' '--with-openssl=/usr' '--enable-htcp' '--enable-forw-via-db' '--enable-cache-digests' '--enable-referer-log' '--enable-arp-acl' '--enable-pf-transparent' '--enable-follow-x-forwarded-for' '--with-large-files' '--enable-large-cache-files' '--enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbian Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish Ukrainian-1251  Ukrainian-koi8-u Ukrainian-utf8' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=amd64-portbld-freebsd8.1' 'build_alias=amd64-portbld-freebsd8.1' 'CC=cc' 'CFLAGS=-O2 -pipe -I/usr/local/include -I/usr/local/include -I/usr/include -DLDAP_DEPRECATED -fno-strict-aliasing' 'LDFLAGS= -L/usr/local/lib -L/usr/local/lib -Wl,-rpath=/usr/lib:/usr/local/lib -L/usr/lib' 'CPPFLAGS=-I/usr/local/include' 'CPP=cpp'
    

    O erro no system.log é:

    Aug 21 17:44:45 pfSense squid[22931]: Bungled (null) line 182: http_reply_access allow all
    Aug 21 17:44:50 pfSense php: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was '2013/08/21 17:44:45| parseConfigFile: squid.conf:5 unrecognized: 'dns_v4_first' 2013/08/21 17:44:45| parseConfigFile: squid.conf:9 unrecognized: 'error_default_language' 2013/08/21 17:44:45| parseConfigFile: squid.conf:16 unrecognized: 'sslcrtd_children' 2013/08/21 17:44:45| ACL name 'all' not defined! FATAL: Bungled (null) line 182: http_reply_access allow all Squid Cache (Version 2.7.STABLE9): Terminated abnormally.'
    


  • Na minha opinião, trata-se de outro assunto, apesar de serem dependentes um do outro.

    Seu problema inicial era apenas da instalação do Squid.
    Acho que você deveria deixar este tópico como [resolvido] e abrir um outro específico para isto.



  • @johnnybe:

    Na minha opinião, trata-se de outro assunto, apesar de serem dependentes um do outro.

    Seu problema inicial era apenas da instalação do Squid.
    Acho que você deveria deixar este tópico como [resolvido] e abrir um outro específico para isto.

    Tem razão, eu usei o mesmo para não ficar abrindo muitos tópicos em seguida.
    De qualquer maneira, foi resolvido removendo e instalando,  somente reinstalar não resolveu.
    Obrigado mais uma vez pela boa vontade.


Log in to reply