Ping permission on SSH



  • I hace formed the new user on pfsense web but that user dont having to ping on ssh. When I use to ping, it is shown no permission.
    What can I do for having to ping and How?

    Thanks you in advance.



  • No anyone to answer ?


  • Banned

    "ping on ssh" makes zero sense.



  • Yes, please rephrase your question.


  • LAYER 8 Global Moderator

    @OP – do you mean when you ssh into pfsense, you can not ping?  Ping what?  Can you post a screenshot of what you think is not working.

    Is this what your talking about?

    [2.1-RC1][johnpoz@pfsense.local.lan]/home/johnpoz(1): ping www.google.com
    ping: socket: Operation not permitted
    [2.1-RC1][johnpoz@pfsense.local.lan]/home/johnpoz(2):

    This is normal behavior since your not root, I do believe raw sockets is limited to root..  More that couple ways to solve that I would think..  sudo package would be one way

    http://doc.pfsense.org/index.php/Sudo_Package

    You could prob set sticky on /sbin/ping to allow it to always run as root.

    There normally always more than 1 way to skin the cat.

    So yeah setting +s works

    [2.1-RC1][root@pfsense.local.lan]/root(1): cd /sbin
    [2.1-RC1][root@pfsense.local.lan]/sbin(2): ls -la ping
    -r-xr-xr-x  1 root  wheel  24348 Mar 21  2012 ping
    [2.1-RC1][root@pfsense.local.lan]/sbin(3): chmod +s ping
    [2.1-RC1][root@pfsense.local.lan]/sbin(4): ls -la ping
    -r-sr-sr-x  1 root  wheel  24348 Mar 21  2012 ping
    [2.1-RC1][root@pfsense.local.lan]/sbin(5):

    Notice s is now set on the ping command

    [2.1-RC1][johnpoz@pfsense.local.lan]/home/johnpoz(2): ping www.google.com
    PING www.google.com (74.125.225.211): 56 data bytes
    64 bytes from 74.125.225.211: icmp_seq=0 ttl=52 time=34.325 ms
    64 bytes from 74.125.225.211: icmp_seq=1 ttl=52 time=36.023 ms

    Not sure that is a good idea ;)  sudo might be a more secure way about going about it ;)



  • Yeah John I talking about as you mentioned. I going to try your solution thanks

    [2.1-RC1][johnpoz@pfsense.local.lan]/home/johnpoz(1): ping www.google.com
    ping: socket: Operation not permitted
    [2.1-RC1][johnpoz@pfsense.local.lan]/home/johnpoz(2):

    This is normal behavior since your not root, I do believe raw sockets is limited to root..  More that couple ways to solve that I would think..  sudo package would be one way



  • Thank you againg John

    So is there any documents that  relate to pfsense commands ?


  • LAYER 8 Global Moderator

    Its a tweaked version of freebsd, so yeah those commands are pfsense commands


Log in to reply