RC 2.1 (i386) - Port alias not working

  • Hello,

    I noticed in the 2.1 release that Port Alias is not working as expected.
    I made some screenshots to make it a bit more clear.

    There are (for testing) 2 ports defined in the port Alias group (called EXT_port_TCP_global). My wireless subnet may access those ports, so I placed a accept rule for this alias.
    But the firewall status tells me the port is blocked.

    When I create a accept rule without port alias, but with port 5228 (example port) it works as expected.

    You will see in the screenshots multiple port aliasses, none of them are working.

    Is this a bug or my wrong thinking ?

  • Banned

    Your protocol there is UDP. You get TCP blocked.

  • @doktornotor:

    Your protocol there is UDP. You get TCP blocked.

    Sorry, I was not clear. I'm talking about the rule before the last one.
    The one with EXT_port_TCP_global.

  • Ok, back to basics.
    I removed all my INT_subnet_* rules and made a new screenshot.

    Still no luck.

    How can you explain, If I put a accept rule with only port 5228, it works ?

  • Banned

    Great. What is "blackstain"WIRELESS in the firewall log?

  • Ok, new firewall log with the rules from reply #3 is my vlan4wireless network

  • Damn, it was my mistake.
    I took vlan4wireless address instead of vlan4wireless net as source.

    I changed it to to "vlan4wireless net" as source and it works now.

  • Banned

    Well, good that it works. Other than that, it helps to name the aliases so that they make things more obvious, rather than obscuring them. :D

Log in to reply